Certbot "system" dropdown Godaddy


#1

All I know is that it’s linux. Which one, I don’t know. Would like to use let’s encrypt but I’m stupid about the linux version godaddy is using for my “economy linux hosting” account. Thanks.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:kickbackwoodcrafts.com

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

The most important thing is whether you have SSH access or not.

You are using a cPanel hosting service, which may or may not allow SSH access.

To use Certbot, you must have SSH access, and ideally root access. You won’t have root access, but it’s worth checking for SSH access.

You can search this forum for threads about GoDaddy, but the summary is basically that GoDaddy makes it difficult to integrate Let’s Encrypt in any way, and they disable cPanel’s AutoSSL functionality which would otherwise give you automatic free SSL.

You can use sites like zerossl.com and gethttpsforfree.com to manually create Let’s Encrypt certificates to install to your cPanel service, but since Let’s Encrypt certificates only have a 90 day duration, you would find yourself doing this quite often.

There aren’t really any great options.

If you do have SSH access, maybe take a look at this forum post, somebody figured out how to use acme.sh (an alternative to Certbot) with a custom cPanel hook to automate Let’s Encrypt on GoDaddy cPanel services.


#3

thanks. I do have ssh access and I guess I’ll try acme.sh. Thanks, again.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.