I have a problem generating a ssl certificate for a domain name

Hello, i have a problem installing Let’s Encrypt Certificate on the cPanel of a hosting provider

My domain is: ilovemobile.fr

I ran this command:

It produced this output:

My web server is (include version): i don’t know

The operating system my web server runs on is (include version): i don’t know

My hosting provider, if applicable, is: O2Switch

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel latest version i think

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

If you have a shared hosting plan and only have cPanel (i.e., no SSH root access/Virtual Private Server), then the only one who can fix this issue for you, is your hosting provider.

Maybe Its Because the process of pointing the dns to my hostings server is not yet complete.

Any ideas about this?

Again thanks

Where’s your DNS pointing to now? If it’s not the same server from the hosting provider you’re using the cPanel from, it’s not going to work.

Well it is still in process of pointing to the server of my host i think, i started the process today in the afternoon.

Then I would advise you to wait with getting the certificate in your new hosting providers cPanel until your DNS is updated and fully propogated. Let’s Encrypt needs to be able to connect to the server which is trying to get the certificate to be able to validate the hostname (disregarding exceptions with different challenges/plugins for simplicity).

Ok, thank you for your reply.

However, the 404 error page that i’m getting when i go to ilovemobile.fr is due to the changing of the DNS ?

Thank you again

Your domain still doesn’t point to the O2Switch cPanel server. It should by now, if you had configured it correctly.

Can you share what instructions O2Switch gave you for the setup of your DNS?

They said to change the DNS Server from the domain provider to their DNS server
and that is what i did yesterday.

Where did you do it? In your OVH control panel?

Because it is still pointing to OVH nameservers, not O2Switch nameservers. The process definitely does not take 20+ hours.

Could you take a screenshot of your nameserver settings in OVH?

I did it on OVH cpanel, however it seems it’s still in process