Https not working

My website seems not to be working with HTTPS. Yesterday was the 2 month anniversary of installing a Letsencrypt certificate. I ran the letsencrypt.exe and installed a fresh certificate but the website still does not work using HTTPS. It seems to be ok using HTTP…

Any thoughts on what might be the problem…?

Many thanks…


Is your bindings fine??
Is there any rewrite rules there??
What is the LE client you are using here?

I haven’t changed anything at all since it was working ok yesterday

The bindings seem to be ok - there is an https entry for port 443

The only “rewrite” thing I know of is a coded redirect in the default web page that redirects requests to the https version of the site url - if that is what you mean…?

I’m using “LetsEncypt1.9.4” on Windows 2016 - is that what you were asking ?


I should also add that when I ran letsencrypt.exe, a certificate did seem to get created inside a newly created .well-known/acme-challenge directory so it looks like a new certificate was created - but not totally familiar with how this all works…?

check it is using newly created certs

Ah yes of course… thank you SO MUCH - i completely forgot about applying
the certificate…

it works again… thank you - very much appreciated


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.