HTTPS is working, but HTTP no longer works

I have installed Let’s Encrypt, but I noticed right after installation, only the HTTPS is working after using the forwarding option in setup with Linux Ubuntu command line to do so. The HTTP is no longer working, meaning that the site is now displaying the following message:

" This site can’t be reached

MyWebSite.com took too long to respond.
Try:

*** Checking the connection**
*** Checking the proxy and the firewall**
*** [Running Windows Network Diagnostics](javascript:diagnoseErrors())**

ERR_CONNECTION_TIMED_OUT"

Also, I have gone into the Apache 2 directory ("/etc/apache2/sites-available/mywebsite.com.conf"), and reset everything back to allowing port 80 through, but it still never does anything to allow the “HTTP” back. I believe that once before when I’ve installed Let’s Encrypt, I was still able to access BOTH “HTTP” & “HTTPS”, but now only “HTTPS” is working.

1 Like

Hi,

Please provide us your domain name so we can perform tests.

This is indeed the intented behaviour…

Thank you

1 Like

http://aceypscraperpro.com (not working)
https://aceypscraperpro.com (working)

THANKS.

1 Like

Hi,

Please check your server / router firewalls and port forwarding, as both port 80 and 443 are filtered.

portqry -e 80 -n aceypscraperpro.com
Querying target system called:
 aceypscraperpro.com
Attempting to resolve name to IP address...
Name resolved to 65.32.75.89
querying...
TCP port 80 (http service): FILTERED

portqry -e 443 -n aceypscraperpro.com
Querying target system called:
 aceypscraperpro.com
Attempting to resolve name to IP address...
Name resolved to 65.32.75.89
querying...
TCP port 443 (https service): FILTERED

Thank you

1 Like

Yeah, but if port 443 was being filtered, then why is it working, or in other words, why is it still accessible if this was the issue?

Thanks brother! You were right! I absolutely forgot about this. I had this as the solution in my mind last week, but forgot to update the Port Forwarding in my router. I only had https enabled (443) instead of having both 443 & 80 forwarding.

Thanks again!

3 Likes

Glad to see it working…
P.S. I have no idea why it’s working… (I suspect it showed filtered because Spectrum did not want people to scan others’ ports…)

1 Like

No, it was my Netgear router where I have to set “port forwarding” for BOTH ports 80 & 443 in order for the site to show up for both http & https. Spectrum doesn’t block any ports.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.