Forum cant load CSS... when ssl activated


#1

Hey guys,

I have a big problem.
I installed letsencrypt today.
Root directory = no problem
Subdoamin = no problem
Folder = No css, js… Only HTML. White page with font.
Its a /forum folder in the root directory.
The forum is created with MyBB.
There is no problem when i use http:// instead of https://

Does someone know what i can try? I already tried permissions, reinstalling certs and reinstalling the vhosts.

Thank you!


#2

Is it possible to post the URL? Perhaps via a personal message if you don’t want it publicly on the board?

Also, you could look with developer toolbars like the "Inspect’ button in the right mouse button menu in Chrome for example (or just press “F12” and it will pop up) and go to the “Console” tab of the toolbar. Then reload your Forum and look what kind of funky error messages it will show.


#3

Hey,

I removed SSL again until I have a solution, so the URL wont help u.
I already checked the Traffic. There are like 10 packets. The most of have a green little circle, the others a gray. I think it means trusted and untrusted. (Btw. The Firefox URL bar means parts untrusted) But i dont understand why it lists green and grey. All images and files are in the same folder and same url.
I reinstalled the cert. Force https, easy… No change. I can access the root folder but not this one.
Other Subdomains with folders work.

Thats how it looks like:


#4

Yes, obviously something is wrong, not doubting that. But what, I can’t say without more information you’ll have to provide. Look at the console for things like error messages or “404 file not found” messages on .js and .css files. Perhaps the folder which serves those files has a .htaccess file in it, who knows.


#5

No, nothing like that. Everything is there. http works really fine. Only https not.
But atm i cant test again. I tried to reinstall some times so now too many already used…


#6

You don’t need to request a new certificate for every time you turn it on. You can re-use the older ones until they expire.


#7

Perhaps your forum software is referencing the CSS and Javascript files via HTTP URLs, and the browser is preventing them from loading over HTTP on a HTTPS page (because this could compromise the security of the HTTPS connection).

If that’s the case, the solution is to configure the forum software to use the HTTPS base URL for its CSS and Javascript files. I’m not familiar with MyBB, but some quick Googling suggests you should change the $mybb->settings['bburl'] setting to use the HTTPS version of your URL.


#8

Now i know this too motoko :smiley:

@jmorahan I love you! It worked!