Failure to request a certificate

Hi, I tried running a modded fabric minecraft server through and wings and apperently it could not find a authenticate my domain. I am very new to linux, and I just wanted to have a hassle free experience trying to make a server

My domain is:

I ran this command: "Set the FDQN to use for Let's Encrypt ("

It produced this output:

(I originally censored the domain, but now I realize it's needed.)

My web server is (include version): (I don't know)

The operating system my web server runs on is (include version): Ubuntu 22.04 LTS

My hosting provider, if applicable, is: No-IP

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): (No idea what this is)

You need to make sure that port 80 is open on your server's firewall, and that the port has been forwarded on your modem/router.

Make sure also that your ISP allows you to host servers on port 80, because some ISPs block it on their residential services.


How would I open port 80? (and forward it to a router)

Don't know, it depends on your internet provider and what modem/router hardware you have.

Something like How to port forward a Charter router | PureVPN might help you.

General networking and server admin is not an issue this forum can help you with.


I have a TP-link W2400 if that helps anyone. Not sure where to get advice to open such a port.

After I open a "port 80", will I be able to access the pterodactyl panel?

You should be able find such answer in the manual, please look at these links for the manual

1 Like

What do I do here?

You likely want External TCP Port 80 mapped to the Internal IP and Internal TCP Port 80 of your server
and External TCP Port 443 mapped to the Internal IP and Internal TCP Port 443 of your server.
Do you know the Internal IP of your server?


I don't. Where can I find all the information I need to fill this out?

Also, a question; "" should be what I should be using to login into the minecraft server?

You need to check with the administrator of your network for what IP Address maps to your server.


What do you mean by administrator?;

My ISP? Or my parents who are paying for it? I have access to the full admin panel.

The person to team who runs the Local Area Network and manage allocation Internal IP Address for the Local Area Network. Not your ISP (the are for the External IP Address).

Which would mean you administrator to what ever the full panel controls.


Using the online tool shows a Public (External to you) IPv4 Address of

Query results for A

;; opcode: QUERY, status: NOERROR, id: 26766
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;	IN	 A


----- Unbound logs -----
Apr 23 22:51:18 unbound[53871:0] notice: init module 0: validator
Apr 23 22:51:18 unbound[53871:0] notice: init module 1: iterator
Apr 23 22:51:18 unbound[53871:0] info: start of service (unbound 1.16.3).

BTW - can be just a Mesh WiFi connected to a router, or it can be a router and Mesh WiFi.
Which is your configuration?

You need access to the router that offers the DHCP IP Address to device on the Local Area Network.
That is the device you find out what IP Address with Issued to the MAC of your server. Also if your server can be logged into on a command line ifconfig works nicely for Unixes and some linuxex, other linuxes you can try ip addr and for Windows ipconfig.


I have two routers and a spectrum modem. One transmits the signal, one is a extender.

How would I find this DHCP IP in the router?

You likely need to read the manual for the router that is NOT the Extender and check the Advanced Router Settings.


This has gone so far off-topic and so far from what this forum was intended to do ...
That I really don't know what to say or if I should even keep reading ...


Okay, I'll try to do that

Go to a commad prompt
Execute ifconfig if not found
Execute ip addr
And share the results.

Also look for IP v4 addresses that start with 198.168. if there is only one that is the IP addr you are seeking.



Although I'm gonna censor it a bit because I don't want people to know (due to websites or something telling people to not share their internal IP, I just want to be cautious)