Error WP Encrypt: Challenge self check failed for domain schenkautomatisering.nl


#1

Please fill out the fields below so we can help you better.

My domain is:
schenkautomatisering.nl

I ran this command (button);
Generate Certificate

It produced this output:
Challenge self check failed for domain schenkautomatisering.nl.

My operating system is (include version):
Unknown

My web server is (include version):
Unknown

My hosting provider, if applicable, is:
Vevuda

I can login to a root shell on my machine (yes or no, or I don’t know):
No

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No, WordPress

Tried:
Change .htaccess and added the lines below

location ~ /.well-known {
allow all;
}


#2

Hi @Schenk,

Sorry, “Generate Certificate” in what interface? There must be some software that you were interacting with at the time that you saw that button.


#3

Do you have this webhosting?: https://vevida.com/webhosting/wordpress-hosting/

If so, they claim the SSL certificate is pre-installed. The “WordPress Hosting” subscription has an “DV SSL-certificate” included, perhaps a Let’s Encrypt certificate.

If you actually do have such a subscription (probably, as you said you don’t a root login and you are using WordPress), chances are you’re better of with asking Vevida support for help with this problem.


#4

Hi @schoen
I am using the WP Encrypt addon for Wordpress.


#5

No, @Osiris, I am not using the wordpress-hosting from Vevida. I have the site installed myself. I am using the cheaper hosting option (and Wordpress hosting wasn’t available when I started).


#6

Hmm. It’s probably not possible for you to install a Let’s Encrypt certificate yourself. Vevida sells a DV certificate with the “Extra Veilig - Een extra veilige website voor jou én je klanten, met zichtbare SSL en 7 dagen back-up.” option for € 3/month.

I’m guessing you’re using the “WP Encrypt” plugin for WordPress, correct? And tried to get a certificate through the following screen:

Unfortunately, from the plugins Description, you can read:

If you don’t have permissions to modify the server configuration, you might be able to still use the certificates if your host provides an interface to upload your own SSL certificates. In that case you can simply upload the generated certificate files there.

And that first part about “permissions to modify the server configuration” is a problem: with shared webhosting, you don’t have those permissions. So, you’re left with the rest of that text: hoping your service provider (Vevida) allows you to upload certificates into some kind of interface, like cPanel. Vevida probably doesn’t offer that, as they sell SSL certificates to their clients themselves. But you can always ask Vevida support!


#7

I wonder what they mean by “zichtbaar” in this sense…

But I agree that it would be helpful to ask Vevida support about this case.


#8

“(…) with visible SSL (…)” is the most accurate translation IMO, probably pointing to a green padlock, i.e. “valid in browsers” or something like that.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.