ERROR - Name does not end in a public suffix ?!?


#1

Please fill out the fields below so we can help you better.

My domain is: каварна.рф

I ran this command:

It produced this output: Name does not end in a public suffix

My operating system is (include version):

My web server is (include version):

My hosting provider, if applicable, is: https://www.superhosting.bg/

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

Hi. I get this error when try to activate SSL from my hosting provider superhosting.bg. They said can’t do anything and to ask you. Will be soon able to use Let’s Encrypt for cyrillic domain names like our: каварна.рф
10x


#2

This is a known bug with the Let’s Encrypt CA software. IDN domains with non-IDN TLDs (e.g. каварна.com) work, but IDN TLDs (example.рф) are currently broken.

A fix is in progress, but for now you just have to wait.


#3

OK. 10x a lot. Where can I check regulary to see if/when problem is fixed!


#4

Subscribing to this issue would probably be the easiest option:


#5

That issue shows that people are now getting success issuing for IDN TLDs (starting today).


#6

I just got this error, running Ubuntu 16.04. Trying to get a cert for a .lan TLD.


#7

I don’t think .lan is a valid (ICANN) TLD. Publicly-trusted CAs are not allowed to issue certificates for internal names (i.e. made-up TLDs).


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.