Error Issuing Certificate

I have had an Organizational SSL Certificate from Commodo for the past five years but it will expire the end of next month. I would like to move to LetsEncrypt but am having problems issuing a certificate. I get the following error.

There was a problem processing your request

I have all A, CNAME, MX and TXT records. What am I missing please.

You are a missing an A record for in your GoDaddy DNS.

It’s not a big deal - you can just uncheck the subdomain when issuing the certificate if you don’t need it.

Otherwise, you’ll need to add that A record.

Many thanks! I thought it was there, but it wasn’t. I just added it and I’m sure that will do the trick but now I have had too many failed authorizations so I guess I’ll have to wait to try it again. :wink:

Much appreciated!!!

I have gone over all my records and compared them with another of my sites. Everything is there now but I still can’t issue a new certificate that includes cpanel and mail.

There was a problem processing your request

This is the error I’m getting now. Would appreciate it if you could tell me what I do now.
Thank you!

Your DNS setup seems odd to me. For a typical cPanel account, everything should point to the same IP address, more or less.

In your case though: 600    IN      A 600  IN      A

I can’t think of any scenario where they would be different. Since the cpanel. authorization is succeeding, I imagine that both domains should use the 142. IP address.

On the other hand, if mail. is intentionally pointing to a different server because e.g. your mail is served by a different server, then the server you’re issuing the certificate from simply won’t be able to issue a certificate for mail. - it has no way to demonstrate control of that subdomain.

Finally, you can use the “dry-run” button on the user interface to test things out without hitting Let’s Encrypt rate limits (assuming the plugin is up to date).

My mail server ( uses but their dedicated IP is Apparently it has to be like that for “banner to match”? I honestly know nothing about these settings. I will try it with

OMG thank you!!! That was the problem. You have no idea how much I appreciate your help. Thank you again!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.