DNS problem: NXDOMAIN looking up A for api.heatseakerapp.com

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: api.heatseekerapp.com

I ran this command: sudo certbot --nginx

It produced this output:

My web server is (include version): nginx/1.14.0 (ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.3

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

Details: I have already used certbot to certify heatseekerapp.com (my react frontend), but when I try to do the same for api.heatseekerapp.com (express api), I get the error as seen in the screenshot above. New users can only post 1 screenshot so here are my DNS settings:

CNAME www.heatseekerapp.com heatseekerapp.com
A api.heatseekerapp.com
A heatseekerapp.com
NS heatseekerapp.com ns1.digitalocean.com
NS heatseekerapp.com ns2.digitalocean.com
NS heatseekerapp.com ns3.digitalocean.com

I don't see "api.heatseekerapp.com" in there...
Maybe my eyes are crossed?

Your domain and your nginx vhosts don't match up:


1 Like

Gah sorry, I sometimes forget the …app when I type out the domain name. Edited the original post to correct errors.

I can’t find anything wrong.
Perhaps you made some DNS changes recently that had not been fully propagated…
Please try it again.

FYI: Digital Ocean is using Cloud Flare for DNS
I tried all six IPs and they returned the same number:
ns1.digitalocean.com internet address =
ns1.digitalocean.com AAAA IPv6 address = 2400:cb00:2049:1::adf5:3a33
ns2.digitalocean.com internet address =
ns2.digitalocean.com AAAA IPv6 address = 2400:cb00:2049:1::adf5:3b29
ns3.digitalocean.com internet address =
ns3.digitalocean.com AAAA IPv6 address = 2400:cb00:2049:1::c629:dead
[and someone seems to have a sense of humor]

1 Like

I think the trouble is a repeated typo “seaker” for “seeker” in the certificate request.


Holy crap you’re right. I misspelled the domain name in my nginx config. I have no idea how it worked before that! I’m all certified and its working now.

Thanks so much!!

1 Like

Sometimes the smallest of details can mess up the biggest of plans…
[sounds like every episode of Pinky and the Brain]

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.