NXDOMAIN looking up A for www.turbogramapp.com - check that a DNS record exists for this domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:www.example.com

I ran this command: certbot --nginx

It produced this output: Detail: DNS problem: NXDOMAIN looking up A for www.turbogramapp.com - check that a DNS record exists for this domain

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

My web server is (include version):vps

The operating system my web server runs on is (include version):ubuntu 20.04

My hosting provider, if applicable, is: holland

I can login to a root shell on my machine (yes or no, or I don't know):i dont know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.12.3

I'm pretty sure your domain isn't actually example.com?

1 Like

is it necessary to write my domain?does it make difference??

Yes, it does. Please read the first part of the questionnaire. Otherwise we have nothing to check/debug.

1 Like

I editted that.

Hm, currently there doesn't seem to be anything wrong with your hostname. I can resolve it fine and so do different online tools too:



Did you add the IP address very recently?

1 Like

I added A record in cloudflare dns last night.when I search my domain via http it is ok.

Seems to be OK from the checks I just did indeed. Maybe the Let's Encrypt resolvers just required some more time for the A record to propogate world-wide. You might want to check again if it works now.

1 Like

that doesnt work.same error

And it's not by any chance the hostname turbogramapp.com (without www) you're trying to get a certificate for too? The error really contains www.turbogramapp.com?

1 Like

I just copy pasted.again
NXDOMAIN looking up A for www.turbogrmapp.com - check that a DNS record exists for this domain

Well, that probably is a copy/paste error or typo: the domain turbogrmapp.com does not exist at all. If you're using that domain for your certbot command, you probably need to add the first a in gramapp in stead of the current grmapp.

1 Like

!!!!.I copy pasted the error from my terminal.I own that domain.

You're absolutely sure you don't mean turbogramapp.com?

Exists: turbogramapp.com
Does not exist: turbogrmapp.com
1 Like

well.you are right.that was a typo.excuse me.thank you


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.