NXDOMAIN looking up A for - check that a DNS record exists for this domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:joserepetitor.com

I ran this command:./letsencrypt-auto --apache -d joserepetitor.com -d www.joserepetitor.com

It produced this output: DNS problem: NXDOMAIN looking up A for
www.joserepetitor.com - check that a DNS record exists for this

My web server is (include version):apache

The operating system my web server runs on is (include version):ubuntu 18.04

My hosting provider, if applicable, is:digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @kingofmidas

there is a check of your domain, one hour old - https://check-your-website.server-daten.de/?q=joserepetitor.com

Host T IP-Address is auth. ∑ Queries ∑ Timeout
joserepetitor.com A Frankfurt am Main/Hesse/Germany (DE) - DigitalOcean, LLC
No Hostname found yes 1 0
AAAA yes
www.joserepetitor.com Name Error yes 1 0

The www domain name doesn’t have an ip address -> that’s your error message.

Add the same A entry in your dns configuration.

You need to add a dns record similar to this:

www 3600 in CNAME @ 

or you can just copy the A record:

www 3600 in A

The first option is more resilient (it will carry all dns records from @ to www, and this can have unintended consequences), the second is more performant.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.