Did letsencrypt remove itself?


#1

I am running Ubuntu 16.04 with letsencrypt installed. Or at least I was :grinning:.
I had a daily cron that ran letsencrypt renew and all was fine. I have been doing system updates manually and occasionally.

Today I got an email that said “Your certificate …will expire in 10 days”. I tried manually running the command and got a command not found. The directory looks to be missing the renew file.

ls /etc/letsencrypt
accounts archive csr keys live options-ssl-apache.conf renewal

The LetsEncrypt log file ends with:

2018-01-26 11:30:28,661:INFO:letsencrypt.cli:Cert not yet due for renewal
2018-01-26 11:30:28,661:DEBUG:letsencrypt.cli:no renewal failures

My Google search says nothing about LetsEncrypt un-installing itself, though that’s what I suspect. My search does however say the name has been changed to CertBot. I can’t find CertBot on my system.

So my question is: How do I properly migrate? I don’t want an old letsEncrypt install laying dead on my system.
Thanks.


#2

Hi @joshk03,

Can you run these commands?

locate certbot
locate letsencrypt
dpkg -l certbot letsencrypt


#3

Thanks for the prompt reply @schoen

root@odroid64:~# locate certbot
-bash: locate: command not found
root@odroid64:~# locate letsencrypt
-bash: locate: command not found
root@odroid64:~# dpkg -l certbot letsencrypt
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
rc  letsencrypt    0.4.1-1      all          Let's Encrypt main client
dpkg-query: no packages found matching certbot
root@odroid64:~#

#4

That shows that the package was previously installed and has subsequently been uninstalled. If you want to figure out exactly how that happened, you could look in your /var/log/apt files.

Anyway, you can learn about reinstalling over on https://certbot.eff.org/. The files in /etc are still the same and should work fine with a reinstalled or newer version.


#5

Well wtf…

Ok, the apt history.log shows this entry for install in April, which seems right:

Start-Date: 2017-04-08  00:07:44
Commandline: apt-get install python-letsencrypt-apache
Install: python-augeas:arm64 (0.5.0-1, automatic), libaugeas0:arm64 (1.4.0-0ubuntu1, automatic), python-psutil:arm64 (3.4.2-1, automatic), python-zope.event:arm64 (4.2.0-1, automatic), python-rfc3339:arm64 (1.0-4, automatic), python-acme:arm64 (0.4.1-1, automatic), python-zope.hookable:arm64 (4.0.4-4build2, automatic), python-zope.interface:arm64 (4.1.3-1build1, automatic), python-tz:arm64 (2014.10~dfsg1-0ubuntu2, automatic), augeas-lenses:arm64 (1.4.0-0ubuntu1, automatic), python-configargparse:arm64 (0.10.0-2, automatic), letsencrypt:arm64 (0.4.1-1, automatic), python-zope.component:arm64 (4.2.2-1, automatic), python-letsencrypt:arm64 (0.4.1-1, automatic), python-pyicu:arm64 (1.9.2-2build1, automatic), python-parsedatetime:arm64 (1.4-1, automatic), python-funcsigs:arm64 (0.4-2, automatic), python-dialog:arm64 (3.3.0-2, automatic), python-mock:arm64 (1.3.0-2.1ubuntu1, automatic), python-pbr:arm64 (1.8.0-4ubuntu1, automatic), python-letsencrypt-apache:arm64 (0.4.1-1)
End-Date: 2017-04-08  00:08:04

And this must be the un-install in January in response to my apt-get dist-upgrade command?!

Start-Date: 2018-01-26  17:22:48
Commandline: apt-get dist-upgrade
Install: libqmi-glib5:arm64 (1.16.2-1ubuntu0.16.04.1, automatic), linux-tools-4.4.0-112-generic:arm64 (4.4.0-112.135, automatic), libinput-bin:arm64 (1.6.3-1ubuntu1~16.04.1, automatic), libllvm5.0:arm64 (1:5.0-3~16.04.1, automatic), linux-tools-4.4.0-112:arm64 (4.4.0-112.135, automatic), python-setuptools:arm64 (20.7.0-1, automatic), libdrm-common:arm64 (2.4.83-1~16.04.1, automatic)
Upgrade: libqmi-proxy:arm64 (1.12.6-1, 1.16.2-1ubuntu0.16.04.1), linux-tools-generic:arm64 (4.4.0.82.88, 4.4.0.112.118), libdrm-freedreno1:arm64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libdrm-nouveau2:arm64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), python-acme:arm64 (0.4.1-1, 0.14.2-0ubuntu0.16.04.1), libegl1-mesa-dev:arm64 (12.0.6-0ubuntu0.16.04.1, 17.2.4-0ubuntu1~16.04.4), libegl1-mesa:arm64 (12.0.6-0ubuntu0.16.04.1, 17.2.4-0ubuntu1~16.04.4), libgbm1:arm64 (12.0.6-0ubuntu0.16.04.1, 17.2.4-0ubuntu1~16.04.4), libdrm-amdgpu1:arm64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libdrm-tegra0:arm64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libwayland-egl1-mesa:arm64 (12.0.6-0ubuntu0.16.04.1, 17.2.4-0ubuntu1~16.04.4), libmm-glib0:arm64 (1.4.12-1ubuntu1, 1.6.4-1ubuntu0.16.04.1), libdrm2:arm64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libgl1-mesa-dri:arm64 (12.0.6-0ubuntu0.16.04.1, 17.2.4-0ubuntu1~16.04.4), modemmanager:arm64 (1.4.12-1ubuntu1, 1.6.4-1ubuntu0.16.04.1), libdrm-radeon1:arm64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), mesa-vdpau-drivers:arm64 (12.0.6-0ubuntu0.16.04.1, 17.2.4-0ubuntu1~16.04.4), linux-firmware:arm64 (1.157.15, 1.157.16), libtasn1-6:arm64 (4.7-3ubuntu0.16.04.2, 4.7-3ubuntu0.16.04.3), libdrm-dev:arm64 (2.4.76-1~ubuntu16.04.1, 2.4.83-1~16.04.1), libinput10:arm64 (1.2.3-1ubuntu1, 1.6.3-1ubuntu1~16.04.1)
Remove: letsencrypt:arm64 (0.4.1-1), python-letsencrypt:arm64 (0.4.1-1), python-letsencrypt-apache:arm64 (0.4.1-1)
End-Date: 2018-01-26  17:24:13

And the term.log shows this:

Log started: 2018-01-26  17:22:48
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 204282 files and directories currently installed.)
Removing python-letsencrypt-apache (0.4.1-1) ...
Removing letsencrypt (0.4.1-1) ...
Removing python-letsencrypt (0.4.1-1) ...
Processing trigge
rs for man-db (2.7.5-1) ...
(continues here, nothing more mentioning LetsEncrypt.)

So I don’t understand the reason for the remove action it took.


#6

I don’t remember the packaging history, but I can look into this further if you’re interested. In the meantime, you should be OK reinstalling according to the instructions.


#7

Thank you very much for the instructions, I will start now.
And yes I would love to find out more on what happened. Thank you.


#8

I’m happy to report @schoen 's directions worked well and quickly got cerbot running. I skipped a few steps since I already had certificates. For the sake of future readers, here’s the complete list of commands I ran:

apt-get update
apt-get upgrade
apt-get install software-properties-common
add-apt-repository ppa:certbot/certbot
apt-get update
apt-get upgrade
apt-get install python-certbot-apache

certbot renew --dry-run
certbot renew

And then I edited the cron file to say certbot renew instead of letsencrypt renew


#9

The package should have already set up a timer to run certbot renew twice a day, so you can remove the cron job entirely.

You can double check with “systemctl list-timers”.


#10

Ok, thanks. I removed it from my daily cron job.


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.