Crt vs pem on letsencrypt certonly --standalone


#1

How do I get the certifications in .crt andprivate.key instead of .pem?

I use mup to deploy my meteor app onto a server running ubuntu 16.04.
mup requires .crt instead of .pem to run the app on https.
I used standalone mode and a fresh install via apt install.

The why and where is explained here and here


#2

You should try what bmw wrote on GitHub.

Different people have different habits about what to call files, but it’s probably all the same thing.

For “.crt” try using letsencrypt’s “fullchain.pem” file.
For “private.key” try using letsencrypt’s “privkey.pem” file.

I don’t use Meteor, but that also seems to be endorsed by these two guides, at least:

https://voice.kadira.io/meteor-up-let-s-encrypt-based-free-ssl-d17111f69f15


#3

the nginx config of my mup uses an absolute filename for the certs thus I cant use fullchain.pem as a filename. also I tried it and it doesnt work. I also tried renaming the files.


#4

@FinnFrotscher, could you use the absolute path to it on your system, like /etc/letsencrypt/example.com/live/fullchain.pem?


#5

turns out to be a mistake on my side in using mup.
I assumed the ssl config would be done on mup deploy.
It actually happens on mup setup which I did not do. now that I did… it works.
this is the object I use.

ssl: {
      crt: './fullchain.pem',
      key: './privkey.pem',
      port: 443
    },

#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.