Could not find cert file


#1

Hi LE community,

I’m new to Let’s Encrypt, I’m having a weird issue I can’t solve after hours of research.
I have two servers, one running on Debian 7 and one on Debian 8 (both up to date).
Both have a different domain name. I have been able to setup an SSL certificates on both, using Nginx and the standalone command.
However, in the future I don’t want Nginx to stop when updating the certificates or creating new ones for subdomains, so I’d like to use the webroot authenticator.
On both servers, I used this configuration in a setup.ini file to create new certificates for subdomains:

domains = subdomain.domain.com
rsa-key-size = 4096
email = my@email.com
text = True
authenticator = webroot
webroot-path = /absolute/path

And I launched the command:

./letsencrypt-auto --config setup.ini certonly

On Debian 8, no issue, the certificate is created.
On Debian 7, I have the following messages:

Requesting root privileges to run with virtualenv: /root/.local/share/letsencrypt/bin/letsencrypt --config setup.ini certonly
could not find cert file

Does someone have an idea why I got this message? I don’t get why I have this message because I’m attempting to create new certificate, no update here.


#2

I thínk this is because some configuration file in /renewal/ folder (normally /etc/letsencrypt/renewal/) referrers to a certificate in /live/ (in the top of one of the files). I know this is one of the reasons for that error… You should check the config-files in /renewal/ for their existance in /live/ :slightly_smiling:


#3

It worked!! I moved the conf file related to the domain from /etc/letsencrypt/renewal/ and it worked.
Thanks a lot for your answer!!