Corrupted Private Key Means cPANEL is Not Able to Issue Certificates - error:0906D06C:PEM routines:PEM_read_bio:no start line


#1

Please fill out the fields below so we can help you better.

My domain is: www.SelectInvoiceFinance.com

I ran this command: Word Press - Let’s Encrypt widget - Generate Certificate

It produced this output: error:0906D06C:PEM routines:PEM_read_bio:no start line

My operating system is (include version): Windows 7

My web server is (include version):

My hosting provider, if applicable, is: Go Daddy

I can login to a root shell on my machine (yes or no, or I don’t know): No

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Cpanel unsure of version

I corrupted the private key by pasting the public key inside file manager - now I can’t retrieve the private key. So need to generate a new pairing. Yesterday I didn’t know what I am doing, now I know what was done I don’t know how to get out of the mess I made without generating a new pair - both public and private. Go Daddy are being extra special in not helping as it’s for them third party. I would appreciate any help undoing the mess and setting things straight as I have a deadline of close of play today with my client. Many thanks in advance.


#2

I solved this myself by going to the Let’s encrypt corrupted private key file. Deleted this completely. Went back to wordpress widget, hit generate new certificate, then went to Go Daddy SSL and manually installed public and private keys and uploaded them and now the site is again secure.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.