Certificate renewal failure

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: romanava.com.au

I ran this command: ./certbot-auto certonly --webroot -w /var/www/html/ -d romanava.com.au -d www.romanava.com.au

It produced this output:
Do you want to expand and replace this existing certificate with the new
certificate?


(E)xpand/©ancel: E
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for romanava.com.au
http-01 challenge for www.romanava.com.au
Using the webroot path /var/www/html for all unmatched domains.
Waiting for verification…
Challenge failed for domain www.romanava.com.au
Challenge failed for domain romanava.com.au
http-01 challenge for www.romanava.com.au
http-01 challenge for romanava.com.au
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:

My web server is (include version): Apache

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Google Cloud

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 1.5.0

The challenges failed.
I see that you used --webroot -w /var/www/html/ for those names.
Please show the vhost config for those names.

This is not my usual area. I am not sure how to obtain/show the vhost config within Google Cloud.

It seems to be running Apache web server, so it should not be too complicated.
Start with:
apachctl -S

Why did you use --webroot -w /var/www/html/ ?

I get the following response to: apachctl -S
-bash: apachctl: command not found

I used that webfoot command, as I am trying to find similar issues in the support forum for renewing your SSL certificate on Google Cloud.

Sorry I mistyped that - missing an E
try:
apachectl -S

The webroot must match the actual web ROOT used in your system.

I typed in: apachectl -S
I now (still) get: -bash: apachectl: command not found

Must be a older version…
Try:
httpd -S

Thank you for your help. I was able to fix the problem with notes from another thread on the renewal via the Bitnami version of Wordpress.

1 Like