Certificate renew issue on apache2

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: nokelstv.com

I ran this command: sudo certbot renew

It produced this output:

My web server is (include version):
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/nokelstv.com.conf

Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for nokelstv.com
Using the webroot path /var/www/nokelstv.com for all unmatched domains.
Waiting for verification...
Challenge failed for domain nokelstv.com
http-01 challenge for nokelstv.com
Cleaning up challenges
Attempting to renew cert (nokelstv.com) from /etc/letsencrypt/renewal/nokelstv.com.conf produced an unexpected error: Some challenges have failed.. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/nokelstv.com/fullchain.pem (failure)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/nokelstv.com/fullchain.pem (failure)

1 renew failure(s), 0 parse failure(s)


The operating system my web server runs on is (include version): ubuntu: 20.04

My hosting provider, if applicable, is: ssdnodes

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

Please I really need a response to this, the site needs to go live

Do you still need help? If so can you explain?

Because I see you got a cert today and your server is sending it out.


Yeah I fixed it. My webroot was pointing to my /var/www/ instead of /var/letsencrypt


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.