Certificate issued but shows as 'fake' with 'invalid' warning on website


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://sumitajohnson.com

I ran this command:

It produced this output:

This isn’t really a command output but a short description of my problem. SSL Settings in GoDaddy cPanel shows the certificate has been installed with correct issuer name and validity details. However when I actually try to visit the website using https, I get an Invalid certificate (red exclamation) error and details say it was issued by ‘fake’ to ‘fake’.

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): I have SSH access

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): I am using control panel but don’t know where to look for the version.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): I used zerossl.com certificate wizard.

Any help is much appreciated. Thank you!


#2

you are running self-signed cert. did you reload webserver?


#3

Hi,

Are you on a shared hosting? Or using an dedicated IP?
I could see that your certificate is definitely issued, and probably installed correctly.
However, it seems that the cPanel instance either didn’t reload, or you are installing on wrong IP.

Please contact GoDaddy support /or your reseller about this issue.

Thank you


#4

I did not. Don’t know how to. Any tips would be much appreciated.


#5

Hi,

Yes I’m on shared hosting.
@orangepizza also pointed out reloading the webserver(assuming it’s the same as cPanel instance), but I don’t know how to. Godaddy has refused to support this issue since I did not purchase the certificate from them. While I continue to google, any tips would be very helpful!
Thanks so much.


#6

Hi,

I’m really sorry for this…
You’ll need to verify a few things:

  1. Are you pointing your domain to the right IP?
  2. Are you purchased your hosting with a third party / reseller?

If you are sure the server is correct and domain resolve to the right ip, there might just have issues to reload, since every certificate installation would need Web Server to gracefully restart after install (and GoDaddy might not want their server to reload that often). There’s actually nothing we could do to help you out since we don’t have WHM access to that server. You could try to contact their support department to request a “gracefully restart”, complaint that their server certificate was not installed correctly, or tell them to fix the HTTPS. (Since their default server / IP seems weird, because it’s not redirecting to “secure server .net” urls when visiting cPanel). Otherwise, you could try to wait for 12 hours, and hopefully their web server would reload once so your certificate would be in effect.

P.S. GoDaddy doesn’t really want to support users that aren’t buying certificate from them… Maybe you might want to consider other providers that support let’s encrypt… For future business…

Thank you


#7

Hi @stevenzhu,

My domain is pointing to the right IP.
My hosting service as well as domain, are both from GoDaddy.
The domain in question is the primary domain on this hosting service.
I believe this part is good.

As far I know, GoDaddy offers WHM access only for VPS & Dedicated Servers. And since I’m on a shared hosting plan, I don’t get WHM access.

However, I am going to call them up again and request for a restart. If they still don’t agree to help, my only option would be to wait.

Thanks so much for your help!


#8

Interesting Update:

The certificate works like a charm on the other two domains/websites hosted on the same service, without the need to restart any services.
It’s only the primary domain that is, for some reason, not picking up the cert.
Any suggestions are much appreciated! Thank you!


split this topic #9

A post was split to a new topic: Chromium doesn’t recognize certificate


closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.