"fake" cert in godaddy

My domain is: spotiads.com

My hosting provider, if applicable, is: godaddy.com

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel

when i tried to enter to my website (https://spotiads.com) and I look the “alert” about my certificate it shows me “Fake” and “My Company Name LTD.” like a issuer of ssl certificate

If i delete my let’s encrypt cert it shows me the same

i have some pages more


But there it works fine

I used zerossl.com to generate the certs

I don’t know what i need to do

You definitely issued these certificates, but however you applied them in GoDaddy’s control panel seems to have not taken effect. You might need to work with GoDaddy on this part, as the Let’s Encrypt part worked.

a few minutes ago I called a technical support and the best they told me "you did not buy the certificates with us, we can not help you"
I hate them…

Do you have a control panel that allows you to upload/import externally-generated certificates?

Yes, trough cPanel
like it https://youtu.be/QMUkDxzf2Qs?t=3m49s

Did you import the certificate that you generated on zerossl using your cPanel? Did it claim to have succeeded in importing it?


I had success to import it

It looks like you’ve done the right thing, and that looks like some kind of bug in GoDaddy’s hosting setup, then. It’s frustrating if they won’t help you investigate it because the certificate wasn’t from them.

Maybe you could try asking on the cPanel forums to see if other people using cPanel with GoDaddy have run into a similar problem before? Or even a GoDaddy customer forum, if they have one?

Thanks schoen

I will try on both, I’m not sure if there is a godaddy forum but I will investigate and ask in cpanel forums

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.