Certificate Invalid

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: visuallysweet.com

I ran this command: ./certbot-auto certonly --webroot -w /opt/bitnami/apps/wordpress/htdocs/ -d visuallysweet.com -d www.visuallysweet.com

It produced this output: You have an existing certificate that has exactly the same domains or certificate name you requested and isn’t clos
e to expiry.
(ref: /etc/letsencrypt/renewal/visuallysweet.com.conf)
What would you like to do?

1: Keep the existing certificate for now
2: Renew & replace the cert (limit ~5 per 7 days)

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel):

My web server is (include version):

The operating system my web server runs on is (include version): Debian GNU/Linux

My hosting provider, if applicable, is: Google Cloud Platform

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Can you show us the output of “sudo ./certbot-auto certificates”?

It seems that you have a valid certificate, but your website isn’t using it.


Where did you install the certificate, or what did you configure to use it? What’s terminating TLS for your website? Your own web server? A load balancer? Installed on your server? A managed service?

Whatever it is might simply need to be reloaded or restarted. Or it might be configured with an out-of-date copy of Certbot’s files, and whatever process was used to configure it might need to be repeated.

1 Like

I installed it SSH in Google Cloud Platform here is the produced output :
./certbot-auto has insecure permissions!
To learn how to fix them, visit Certbot-auto deployment best practices
certbot-auto [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …
Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certbot: error: unrecognized arguments: certificate

1 Like

I’m trying to repeat it but its saying that it already exists and wont let me do the steps again. It’s just Bitnami WordPress that I’m using it with.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.