Certbot runtime error - library problem?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
elnoraspantry.com
I ran this command:
sudo certbot --apache
It produced this output:
Traceback (most recent call last):
File “/usr/bin/certbot”, line 6, in
from pkg_resources import load_entry_point
File “/usr/local/lib/python3.7/site-packages/pkg_resources/init.py”, line 3250, in
@_call_aside
File “/usr/local/lib/python3.7/site-packages/pkg_resources/init.py”, line 3234, in _call_aside
f(*args, **kwargs)
File “/usr/local/lib/python3.7/site-packages/pkg_resources/init.py”, line 3263, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File “/usr/local/lib/python3.7/site-packages/pkg_resources/init.py”, line 583, in _build_master
ws.require(requires)
File “/usr/local/lib/python3.7/site-packages/pkg_resources/init.py”, line 900, in require
needed = self.resolve(parse_requirements(requirements))
File “/usr/local/lib/python3.7/site-packages/pkg_resources/init.py”, line 786, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The ‘six>=1.9’ distribution was not found and is required by mock

My web server is (include version):
httpd -v
Server version: Apache/2.4.41 (Fedora)
Server built: Oct 3 2019 08:50:37

The operating system my web server runs on is (include version):
Linux steve-2.wowway.com 5.2.18-200.fc30.x86_64 #1 SMP Tue Oct 1 13:14:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
My hosting provider, if applicable, is:
sudo certbot --apache
I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
from dnf output: version 0.38.0 release 1.fc30

What do I need to upgrade to fix this error?

1 Like

To confirm - you are running Fedora 30 as your OS?

If so, and you followed the official instructions for Fedora 26+, then perhaps try using:

dnf reinstall python3-six

which is part of the dependencies that should have been installed to begin with.

Certbot from FC30’s repo is at certbot-0.39.0-1.fc30.noarch, so I would be super double sure to check where you installed Certbot from.

2 Likes

Thanks - will try that - I am on Fedora 30

Thanks - problem fixed after reinstall

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.