Certbot has problem setting up the virtual environment

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
solar.neroth.org (showing one of them, I have a few subdomains)

I ran this command:
certbot-auto renew solar.neroth.org --standalone (usually I run without the specific subdomain to renew all)

It produced this output:
[Very long output – including what I consider relevant, I can provide more if needed]
(During Bootstrapping dependencies, all modules are already the latest)
0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
Creating virtual environment…
Installing Python packages…
Had a problem while installing Python packages

[pip prints a very long list of errors, showing the ending below… again can provide more if needed]

Requirement already satisfied: setuptools>=1.0 in /opt/eff.org/certbot/venv/lib/python2.7/site-packages (from josepy==1.1.0->-r /tmp/tmp.5hvrMhpImn/letsencrypt-auto-requirements.txt (line 87))
THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
pycparser==2.19 from https://www.piwheels.org/simple/pycparser/pycparser-2.19-py2.py3-none-any.whl#sha256=344870c533812cb119c5475b5aed033ec546118711338ff9b2b78e67098d64e7 (from -r /tmp/tmp.5hvrMhpImn/letsencrypt-auto-requirements.txt (line 105)):
Expected sha256 a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3
Got 344870c533812cb119c5475b5aed033ec546118711338ff9b2b78e67098d64e7

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .

My web server is (include version):
Server version: Apache/2.4.25 (Raspbian)

The operating system my web server runs on is (include version):
Raspbian GNU/Linux 9 (stretch)
Linux 4.14.98-v7+ #1200 SMP armv7l GNU/Linux

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes, that is from where the command was run. I have auto updated many times every 2-3 months without problems.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot-auto --version will trigger the same output as above

All my certificates are coming up for renewal. I just have/had enough knowledge to setup and run auto update from then. If you would like me to provide additional info, please tell me explicit linux commands or certbot commands

PS. Yes the OS packages have been updated with normal scripts after the last renewal.

It is ok by me, if I need to recreate all new certifiicates, but then I need to learn how to install the new ones… ( I have forgotten how I initially setup the certifiacte inside my server).

Hi @Cqc

that's a known problem. Please check

Juergen, Thank you very much for the very prompt response! Yes the solutions was trivial.

I am repeating it here for others quick reference. Read the above for details.

Just rename /etc/pip.conf (and delete it when you are satisfied everything works).
It worked well here on a Rasperry Pie 3.

I highly recommend, if possible, please add this one line summary as a possible solution at the messages that come up at the end of the current report when the script fails. It would reduce the future support workload for all… Thank you again!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.