Can't renew Certificate for domain


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: nologam.com

I ran this command: certbot certonly --webroot --webroot-path /home/web/nologam.com -d nologam.com

It produced this output:

2018-04-19 14:01:01,836:DEBUG:certbot.reporter:Reporting to user: The following errors were reported by the server:

 Domain: nologam.com
 Type:   connection
 Detail: Fetching http://nologam.com/.well-known/acme-challenge/rkoiX6oOQPeNEdiG64lrb2xPm10tevWq6X9YGAVWGnU: Timeout

 To fix these errors, please make sure that your domain name was entered correctly and the DNS A record(s) for that domain contain(s) the right IP address. Additionally, please check that your computer has a publicly routable IP addre    ss and that no firewalls are preventing the server from communicating with the client. If you're using the webroot plugin, you should also verify that you are serving files from the webroot path you provided.
 2018-04-19 14:01:01,836:INFO:certbot.auth_handler:Cleaning up challenges
 2018-04-19 14:01:01,836:DEBUG:certbot.plugins.webroot:Removing /home/web/nologam.com/.well-known/acme-challenge/rkoiX6oOQPeNEdiG64lrb2xPm10tevWq6X9YGAVWGnU
 2018-04-19 14:01:01,836:DEBUG:certbot.plugins.webroot:All challenges cleaned up, removing /home/web/nologam.com/.well-known/acme-challenge
 2018-04-19 14:01:01,837:DEBUG:certbot.main:Exiting abnormally:

My web server is (include version): nginx/1.10.3

The operating system my web server runs on is (include version): Debian 9.4

My hosting provider, if applicable, is: Hetzner (Dedicated Server)

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Hi,

Your server is not responding to IPV6 as you have the IPV6 assigned.

Please remove that address from your dns record, or enable your IPV6 address on server.

P.S.
::0 seems to be a IPV6 gateway address. (So it probably won’t even open the web)

Thank you


#3

Thanks for that @stevenzhu

All I needed was a fresh set of eyes to see my issue.
Thanks a lot :slight_smile:


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.