Certificate Install Trouble


#1

Hi Guys, I have a problem when i want to renew the certificate for a domain, below you have the issue

root@srvcrhost:~# **sudo certbot certonly --webroot --webroot-path=/var/www/domain.info /public_html -d domain.info
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for domain.info
Using the webroot path /var/www/domain.info/public_html for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. domain.info (http-01): urn:acme:error:conn ection :: The server could not connect to the client to verify the domain :: Fet ching http://domain.info/.well-known/acme-challenge/yh9BKe5_fXZmD2JUeHXHl5 vhzB2rsq7S1DLkUDlMXGU: Timeout

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: domain.info
    Type: connection
    Detail: Fetching
    http://domain.info/.well-known/acme-challenge/yh9BKe5_fXZmD2JUeHXHl5vhz B2rsq7S1DLkUDlMXGU:
    Timeout

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

I ran this command:

sudo certbot certonly --webroot --webroot-path=/var/www/domain.info /public_html -d domain.info

My web server is (include version):
nginx
The operating system my web server runs on is (include version):
ubuntu 14
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

To renew a certificate, you should use certbot renew. Other than that: please show the affected domain name, nobody can help you without it.


#3

The affected domain name is livesexgirls.info, but on this server i have alot of domains and everythings works very good and with this i have the problem.


#4

Hi @antino1921,

It’s really hard to debug the issue without the real domain name.

You should double check that your site can serve the cahallenge correctly.

mkdir -p /var/www/domain.info/public_html/.well-known/acme-challenge/
echo -n "this is a test" > /var/www/domain.info/public_html/.well-known/acme-challenge/test

Once done, try to reach this file with your browser.

http://domain.info/.well-known/acme-challenge/test

If you can’t reach it then you should re-check your web server configuration, if you can reach it using IPv4 then the problem could be your domain is advertising AAAA records (IPv6) but it is not configured properly on your server and Let’s Encrypt will prefer IPv6 over IPv4… who knows :wink:

As I said, if you provide your real domain name we could help you better.

Edit: I’ve just seen you posted the domain name and yes, you are advertising an AAAA record but it is not reachable using that IPv6 address, fix the IPv6 issue or remove the AAAA address for that domain.

Cheers,
sahsanu


#5

Look into the DNS settings: you offer IPv6, but your server does not respond on IPv6:

$ host livesexgirls.info
livesexgirls.info has address 86.123.141.248
livesexgirls.info has IPv6 address 2a02:2f04:1:11f8::567b:8df8

$ telnet 2a02:2f04:1:11f8::567b:8df8 80
Trying 2a02:2f04:1:11f8::567b:8df8…

IPv6 has higher precedence for the ACME server, either drop that AAAA record or connect your host via ipv6, too.


#6

Hi sahsanu,

I have the same error when i try to do that with your solution.

sudo certbot certonly --webroot --webroot-path=/var/www/livesexgirls.info/public_html -d livesexgirls.info -d www.livesexgirls.info
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for livesexgirls.info
http-01 challenge for www.livesexgirls.info
Using the webroot path /var/www/livesexgirls.info/public_html for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. livesexgirls.info (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://livesexgirls.info/.well-known/acme-challenge/CxJY7LeEgtqvOYCtK4tIxS7kcskiUN6oSzcsTfz8nmQ: Timeout, www.livesexgirls.info (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://www.livesexgirls.info/.well-known/acme-challenge/jV-KOO7Sx0poEAjxVfPLxv2uUiQDE2GMahGsyqQ1duk: Timeout

IMPORTANT NOTES:


#7

ipv6 is set
root@srvcrhost:~# ip -6 address show eno1
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 2a02:2f04:111:f700:baac:6fff:fe11:c791/64 scope global mngtmpaddr dynamic
valid_lft forever preferred_lft forever
inet6 fe80::baac:6fff:fe11:c791/64 scope link
valid_lft forever preferred_lft forever


#8

Look closely at your DNS records:
https://unboundtest.com/m/AAAA/livesexgirls.info/TA5KBVSW

IN AAAA 2a02:2f04:1:11f8::567b:8df8

The address you configured your interface for is NOT published via DNS.


#9

But is not possible to install via ipv4?


#10

Besides having a wrong AAAA record is useless in general, IPv6 has higher precedence over IPv4 when it comes to authorization. As long as you publish AAAA records, you won’t be able to authorize via IPv4.


#11

Hi @antino1921,

Of course it is possible to install via IPv4, the problem is that you have not configured your server and/or web server to answer requests made via IPv6 so, fix that or remove the AAAA records for your domain because they are still advertising IPv6 records.

There is no need to have IPv6 records for your domain if no one can access it via IPv6, remove the AAAA records and you could get the cert.

Cheers,
sahsanu


#12

@antino1921, congratulations, I see you have removed the AAAA records for your domain and you are already using your new cert :wink:


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.