Certbot isn't resolving my server?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
client.pluricorp.com
I ran this command:

sudo certbot certonly --standalone --preferred-challenges http -d client.pluricorp.com

It produced this output:
Failed authorization procedure. client.pluricorp.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://client.pluricorp.com/.well-known/acme-challenge/XO2-VMmROdEzF_2PzMBGCz4POtK1D2SHk3UKWCGObuU: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: client.pluricorp.com
    Type: connection
    Detail: Fetching
    http://client.pluricorp.com/.well-known/acme-challenge/XO2-VMmROdEzF_2PzMBGCz4POtK1D2SHk3UKWCGObuU:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):

The operating system my web server runs on is (include version):
ubuntu 18.04
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.31.0

I initially tried

sudo certbot --nginx

with a default nginx configuration (straight from apt) minus the servername set to www.client.pluricorp.com and client.pluricorp.com
received the same error.
stopped the nginx server and ran the stand alone
no go
checked https://www.whatsmydns.net/#A/client.pluricorp.com
that my IP listed in DNS A is correct and no AAAA

I also tried using webroot… that didnt work either, but I figure standalone is the best indicator that it has nothing to do with my nginx config.
I put nginx back up with a test.txt at
http://www.client.pluricorp.com/.well-known/acme-challenge/test.txt
http://206.210.196.98/.well-known/acme-challenge/test.txt

??? What am I doing wrong here???

I can’t connect to those locations either. Probably somewhere port 80 is blocked. Perhaps in your firewall, NAT router or your ISP.

Not all source IPs are allowed to connect to your IP.
Do you have some sort of IPS, or Geo-location system, that might be blocking?

curl -Iki http://206.210.196.98/
curl: (7) Failed to connect to 206.210.196.98 port 80: Connection timed out

Thanks, I’m not sure why I didn’t think of that. That’s the problem… the company hosting the virtual machines limited IP access to the ssh port, but I guess it’s a global firewall. I’ll have to resolve this with them. I can see my site from my ip and anyone in house… but no one else on planet earth can see it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.