I can not renew the certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: desa.compufax.cr

I ran this command:

letsencrypt certonly -a manual --email agonzalez@itechcr.com -d desa.compufax.cr

certbot certonly -a webroot -w=/var/www/site1/web -d desa.compufax.cr

letsencrypt certonly -a webroot --webroot-path=/var/www/site1/web -d desa.compufax.cr

It produced this output:

Create a file containing just this data:


And make it available on your web server at this URL:


Press Enter to Continue
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. desa.compufax.cr (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching https://desa.compufax.cr.well-known/acme-challenge/kszZSB2hU7DJAXtojv3IEFF8zgzHAn4FCyuLzPZOKW4: Error getting validation data


  • The following errors were reported by the server:

    Domain: desa.compufax.cr
    Type: connection
    Detail: Fetching
    Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):

PHP 5.6

The operating system my web server runs on is (include version):

GNU/Linux Ubuntu 16.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):


I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The webroot of validation is lost the slash (/)

You have a bad HTTPS redirect on your site.

You need to add a trailing slash to whatever redirect rule you have for HTTP-to-HTTPS.

1 Like

It is correct.

I disable the redirect and the renew work.

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.