Can't install Cert through cPanel plugin


#1

Please fill out the fields below so we can help you better.

My domain is:
http://Agility.events
I ran this command:
I used the cPanel plugin
It produced this output:
Something went wrong, kindly check the letsencrypt log file … the log file (from LiquidWeb support) says: [2016-07-06 08:40:45 -0400] warn [cpanel] Cpanel::Wrap::send_cpwrapd_request error: namespace=[Cpanel] module=[ssl] function=[ADD]: statusmsg=[The adminbin “ssl” in the “Cpanel” namespace call to function “ADD” ended prematurely: The subprocess reported error number 5 when it ended.] at /usr/local/cpanel/Cpanel/Wrap.pm line 123, <$socket> line 1.
My operating system is (include version):
CENTOS 6.8 x86_64 kvm – host
My web server is (include version):
Apache
My hosting provider, if applicable, is:
LiquidWeb
I can login to a root shell on my machine (yes or no, or I don’t know):
No
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):Yes


#2

Hi @SiteCrafter, I think this error might best be reported to LiquidWeb, because it looks like a problem of their integration with Let’s Encrypt software (and they might have access to more log files that would explain what went wrong). If you do have access to other log files with more details, maybe you could post them here.


#3

Because Let’s Encrypt isn’t supported by cPanel yet, there was limited help from the support staff at my host. He could not locate the logs to show a more detailed error message. On the good side, though, he tried doing a certificate installation through WHM and that worked just fine. So I’m good with doing the installations through WHM instead of using cPanel for this task.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.