Cannot verify SSL: "Site can't be reached"

I tried installing an SSL certificate via zerossl but I’m stuck at the Verification stage because when I click the verifications links on the zerossl website I get a message saying “Site can’t be reached”.

My domain is: casa-mena.com

I ran this command: I was following the steps in the zerossl website to install an SSL certificate.

It produced this output: I can’t verify the certificate in the verification state on zerossl.com

My web server is (include version): I’m not sure what “web server” is.

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): no idea

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel 78.0.27

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): I don’t think I’m using Certbot.

1 Like

Godaddy’s (less than helpful) instructions:
https://www.godaddy.com/help/install-a-lets-encrypt-certificate-on-your-cpanel-hosting-account-28023

ZeroSSL is very simple.
If you have TeamViewer, I can step you through the installation.

1 Like