Zero SSL Verification Error with all 3 type of verification

I was using sslforfree.com till now for free SSL, and I believe they were merged with zerossl.com!

I was using a sslforfree.com website to create SSL certificates for my subdomains like developer.norght.com, app.norght.com, etc. for a three month time period.

At this renewal, I sign up for the account on zerossl.com and try to generate certificate for my website, but I am not able to do that and the problem is I am unable to verify my domain by any of three methods mentioned there.



I created email for my domain to get verify email but I never receive email, I inserted DNS records to my Zone editor but they were unable to verify it using DNS, and I also try file uploading method my file is already live at http://developer.norght.com/.well-known/pki-validation/C24C8A155409CE6C12996C9E1E6B2E6A.txt as the documentation mentioned, but again they were unable to verify it using file too.

So, what is going on here! Can anyone please guide me through and how can I generate SSL for my subdomains?

My domain is: developer.norght.com

I ran this command: NA

It produced this output: SS attached with the topic.

My web server is (include version): Hostinger, Premium Hosting

The operating system my web server runs on is (include version): Linux

Thanks,
Kaushik

1 Like

Hi,

Sorry but ZeroSSL and sslforfree are no longer using Let’s Encrypt certificate, please contact their support team and request support there.

They are acquired by APILayer and now has their own intermediate CAs.

https://zerossl.com/help/

4 Likes

Hi @kaushik.gujjar

additional: They may have their own CAA name.

Checking your domain via https://check-your-website.server-daten.de/?q=developer.norght.com

Domainname flag Name Value ∑ Queries ∑ Timeout
developer.norght.com 0 no CAA entry found 1 0
norght.com 5 issue comodoca.com 1 0
5 issue letsencrypt.org 1 0
com 0 no CAA entry found 1 0

Only Letsencrypt and Comodo are allowed to create certificates.

See your error messages: Your CAA blocks.

But I don’t know what’s the required CAA entry. You have to add a new entry, then try it again (the method of your first screenshot).

PS: Checked

https://zerossl.com/help/troubleshoot/caa-records/

sectigo.com

is required, so a Sectigo certificate is created.

6 Likes

Thanks it has solved the issue! I was missing inserting CAA record for zerossl.com website.

If this help to anyone, if you are using zerossl.com to install free SSL certificate and you have another CAA records like letsencrype.com comodo.com you have to insert {0 issue “sectigo.com”} as a CAA entry into you DNS manager.

Thank you guys for the help!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.