ZeroSSL Wont verify my domain

I have tried both the CNAME verification and the file upload but no matter what it tells me that the verification failed.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
yes, cpanel.epizy

1 Like

They don’t use Let’s Encrypt certificates anymore.

You need to contact their support


Honestly, I wrote the FREE SSL CERTIFICATE tool on my site because of how irate I was when sold out to ZeroSSL. It’s an absolutely free acme client for acquiring Let’s Encrypt wildcard certificates rather than supporting ZeroSSL’s greed. Not a permanent solution compared to a client supporting automated renewal, but still works well if you are using a shared host (and thus have no root access).

1 Like

you have two problems.

one, as they already said you, it zerossl that changed style.

the other, is InfinityFree that doesn’t like zerossl (or Let’s Encrypt…) validation servers, because they are robots.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.