Adding ISRG Root X1 on Windows

Hi @schoen I've read this issue affects PCs running Windows XP (Service Pack 2) or earlier. I'm using Windows 7 Ultimate on my laptop and yet I'm running into the same issue on various websites when using Chrome (no problems with Firefox). Can you help? Thank you

Hi, @mel_mel browse to this site using Google Chrome: https://valid-isrgrootx1.letsencrypt.org/ in chrome, then go back to www.investopedia.com and see if it works.

2 Likes

Hi @webprofusion, thanks for replying. I entered that url and I get the same error (see below). I went back to invesopedia and the problem still exists.

@mel_mel
It seems that version of Chrome doesn't yet have the ISRG Root X1 in its' trust store.
What version of Chrome is that?
[can you update it?]

Hi @rg305
The version is: Version 94.0.4606.71 (Official Build) (64-bit).
It says "Chrome is up to date". I was previously using 94.0.4606.61 before updating to the current version a few hours ago to see if that would solve the issue.

Chrome uses the OS root store currently, not?

@Osiris
I thought not.
hmm...
But that could explain why a new Chrome is still having trouble.
Let's check under the hoodie.

I thought Google was planning to ship Chrome with its own store, like Firefox, but currently didn't.

2 Likes

@mel_mel
OK so then we need to treat this like a Windows O/S problem (until told otherwise).
Have you searched this forum for help with updating the Windows cert store?
Like this post:

Hi @rg305

So I downloaded the self-signed ISRG Root X1 .der file and successfully imported the ISRG Root X1 certficate but still getting the error message on some websites. I guess because I need to delete the DST Root CA X3 certificate as well? Would you know how I go about doing that? I'm a novice at all this. Thank you.

start
run

  • mmc.exe
    ctrl-M (add/remove snap-in)
    certificates
    add
    my user account
    finish
    OK

OR

  • certmgr.msc (if available)

(browse to) Trusted Root Certificate Authorities
Certificates
(find the cert and delete it)

1 Like

Hi @rg305
I followed your instructions (option 1) and then saved the "console settings". I then restarted the laptop and ran chrome but the issue still persists

Is that where the web server runs?

Hi @rg305
Web server? Sorry, I'm not sure what that is. I'm connecting to the internet via the wifi from my home broadband router.

@mel_mel
Oh! OK.
I was thinking otherwise...
There is a post that does a good job of explaining all that is needed for older Windows PCs.
Let me see if I can find it for you...

@mel_mel
I haven't found the post I'm looking for...
But try this one:

1 Like

Hi @rg305

I have the isrgrootx1 file downloaded from your previous suggestion, but do you know what he means by "and put it on "Third Party Root Certification Authorities"". I couldn't find that option when I click on the file. Thank you for your help!

@mel_mel, you should be able to double click the file and it should show a window with an "Install Certificate ..." option. Choose Local Machine > Next > Automatically select.. > Next > Finish.

Hi @webprofusion

I had done that first time round and got the message "The import was successful" (see post 442). Unfortunately it did nothing to solve the problem.

@mel_mel sorry I'm out of ideas for now. Maybe use Firefox until things settle down a little.