Account is not valid, has status "deactivated"

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot certonly --webroot -w /var/www -d -d

It produced this output: An unexpected error occurred:
The client lacks sufficient authorization :: Account is not valid, has status "deactivated"

My web server is (include version): nginx/1.25.0

The operating system my web server runs on is (include version): Debian GNU/Linux 11 (bullseye)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.12.0

1 Like

An excerpt from certbot --help all

manage your account:
    register        Create an ACME account
    unregister      Deactivate an ACME account
    update_account  Update an ACME account
    show_account    Display account details
  --agree-tos       Agree to the ACME server's Subscriber Agreement
   -m EMAIL         Email address for important account notifications

I ran this command: certbot register -m
It produced this output: There is an existing account: registration of a duplicate account with this command is currently unsupported

1 Like

What about certbot show_account?

NB: the help page I pasted is from a newer version, yours might be different.


certbot: error: unrecognized arguments: show_account17:05

1 Like

Options for account registration

Specifying this flag
enables registering an
account with no email
address. This is strongly
discouraged, because you
will be unable to receive
notice about impending
expiration or revocation of
your certificates or
problems with your Certbot
installation that will lead
to failure to renew.
(default: False)
-m EMAIL, --email EMAIL
Email used for registration
and recovery contact. Use
comma to register multiple
emails, ex:, (default:
--eff-email Share your e-mail address
with EFF (default: None)
--no-eff-email Don't share your e-mail
address with EFF (default:

Options for account modification

Options for account deactivation.

--account ACCOUNT_ID Account ID to use (default:

1 Like

Possible unrelated to the current problem... but:
Can you update certbot to a newer version?


Can you please tell me how to do this?

1 Like

If you are asking about how to update certbot, start at:


Certbot only allows a single account to be registered per ACME server using the user interface.

You probably need to delete the disabled account first before you can register a new one.

Note that the show_account does not provide more info. I build it and it only shows some account parameters such as the account URI and email address associated with the account. I'm not even sure if the function works with disabled accounts.


That's the end of it:
"Remove certbot-auto and any Certbot OS packages

If you have any Certbot packages installed using an OS package manager like apt , dnf , or yum , you should remove them before installing the Certbot snap to ensure that when you run the command certbot the snap is used rather than the installation from your OS package manager. The exact command to do this depends on your OS, but common examples are sudo apt-get remove certbot , sudo dnf remove certbot , or sudo yum remove certbot"

Then according to the instructions install snapd with the command apt install but the OS does not have apt,apt-get,dnf or yum. There is only dpkg. Now I don't have certbot :frowning:

1 Like

Snap is a separate application, you should be able to install it somehow on Debian.

By the way, if you used apt to remove Certbot, you should be able to use apt again. Preferable to install Snap (see Installing snap on Debian | Snapcraft documentation) and with snap, install Certbot using the guide you already have.


I ran this command: certbot unregister -m
It gave an error
but I haven't had a chance to try the certbot unregister --account command.
and I didn't know what ID to put in the command.

1 Like

I deleted the only way I could dpkg -r
Unfortunately I couldn't find on the website how to download and install the .deb package for installation

Can you install snap?
sudo apt update
sudo apt install snapd


No, I don't have access to apt

How about:
sudo yum install snapd
sudo dnf install epel-release
sudo dnf upgrade
sudo yum install snapd



1 Like

How can your Debian not have apt?


I was given a machine to work on ready to go, I can't say why that happened

1 Like