(98)Address already in use: AH00072 (Bitnami)

Domain name: www.the-ela.com
The command line you ran: Followed the instructions here: https://certbot.eff.org/#ubuntutrusty-apache
the output of that command: See below
name and version of your operating system and your web server: Apache / Ubuntu 14.04
what type of hosting provider you are using, if applicable: Amazon AWS EC2 instance

Hi,
I am trying to follow the instructions on the above link but am getting the following error after executing sudo apt-get install python-certbot-apache
Can you suggest what is should do to fix it?
Many thanks.

  • Starting web server apache2 AH00558: apache2: Could not reliably determine the server’s fully qualified doma in name, using 127.0.0.1. Set the ‘ServerName’ directive globally to suppress th is message
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8 0
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0. 0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    Action ‘start’ failed.
    The Apache error log may have more information.
  • The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
    invoke-rc.d: initscript apache2, action “start” failed.
    Setting up augeas-lenses (1.2.0-0ubuntu1.2) …
    Setting up dialog (1.2-20130928-1) …
    Setting up libaugeas0 (1.2.0-0ubuntu1.2) …
    Setting up python-augeas (0.4.1-2) …
    Setting up python-cffi-backend (1.10.0-0+certbot~trusty+1) …
    Setting up python-configargparse (0.11.0-1+certbot~trusty+1) …
    Setting up python-six (1.10.0-3+certbot~trusty+1) …
    Setting up python-enum34 (0.9.23-1) …
    Setting up python-idna (2.2-1+certbot~trusty+1) …
    Setting up python-ipaddress (1.0.17-1+certbot~trusty+1) …
    Setting up python-pyasn1 (0.1.9-2+certbot~trusty+1) …
    Setting up python-pkg-resources (33.1.1-1+certbot~trusty+1) …
    Setting up python-setuptools (33.1.1-1+certbot~trusty+1) …
    Setting up python-cryptography (1.7.1-2+certbot~trusty+1) …
    Setting up python-openssl (17.0.0-0+certbot~trusty+1) …
    Setting up python-dialog (3.3.0-2+certbot~trusty+1) …
    Setting up python-dnspython (1.15.0-1+certbot~trusty+1) …
    Setting up python-ndg-httpsclient (0.4.2-1+certbot~trusty+1) …
    Setting up python-parsedatetime (2.1-3+certbot~trusty+1) …
    Setting up python-psutil (5.0.1-1+certbot~trusty+2) …
    Setting up python-pyicu (1.5-2ubuntu4) …
    Setting up python-urllib3 (1.19.1-1+certbot~trusty+1) …
    Setting up python-requests (2.12.4-1+certbot~trusty+1) …
    Setting up python-tz (2012c-1ubuntu0.1) …
    Setting up python-rfc3339 (1.0-4+certbot~trusty+1) …
    Setting up ssl-cert (1.0.33) …
    Setting up python-mock (1.0.1-3) …
    Setting up python-acme (0.14.2-0+certbot+14.041) …
    Setting up python-zope.event (4.0.1-0ubuntu1) …
    Setting up python-zope.hookable (3.4.1-8) …
    Setting up python-zope.component (4.0.2-0ubuntu1) …
    Setting up python-certbot (0.14.2-1+certbot+14.041) …
    Setting up certbot (0.14.2-1+certbot+14.041) …
    Processing triggers for ureadahead (0.100.0-16) …
    Processing triggers for ufw (0.34~rc-0ubuntu2) …
    Setting up python-certbot-apache (0.14.2-1+certbot+14.041) …
    Processing triggers for libc-bin (2.19-0ubuntu6.11) …
    bitnami@ip-172-31-26-110:~/apps$ certbot --apache
    The following error was encountered:
    [Errno 13] Permission denied: '/var/log/letsencrypt’
    If running as non-root, set --config-dir, --work-dir, and --logs-dir to writeable paths.

Certbot's standard instructions don't work with Bitnami. In fact, even the first step (installing python-certbot-apache) is likely to cause problems, or at least confusion, since it will pull in Ubuntu's Apache as a dependency alongside Bitnami's Apache which you're presumably already using.

You might have more luck using sudo certbot certonly --webroot but you'll have to update the Apache configuration yourself afterwards to activate HTTPS and point it at your certificate.

If you search this forum for "bitnami" you will see several people have had similar problems and reading about their experiences may be helpful.

Many thanks for your reply. Yes, I have found a number of links to other people who are having similar problems with Bitnami, but none that solve the problem with Bitnami. I will direct my question to them as the instructions on their support page don´t work and need to be updated.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.