ZeroSSL HTTP Verification Failure


#1

Verification path containing “.” symbol “/.well-known/acme-challenge/” is causing that the right file can not be found.

If the verification path was “/well-known/acme-challenge/” i.e. without “.” symbol I wouldn’t have any issues with HTTP verification.

Do you know why this happens? Please share.


#2

Hi @sidem

looks like a problem with your webserver configuration.

What’s your domain name? And your Webserver + operation system?


#3

My guess is…
Windows®

Second guess is…
.htaccess file is blocking files that start with “.”


#4

Thank you JuergenAuer - you’re right - it is the webserver Apache that caused it. I have confirmation from my hosting provider who claims DNS verification is the only manual option for now.


#5

Thanks rg305 - I’ve tried deleting htaccess - still the same, but was worth trying.

Ref. Windows - well I have state of art Win10Pro, so system is not an excuse :wink:


#6

Were you able to create the .well-known folder?


#7

Good point, yes Apache allowed creation of such folder starting with “.”.

It seems that either hosting provider simply wants to force people to buy far more expensive plans with automatically renewed Let’s Encrypt certs or it is tricky for Apache to make such URL’s containing folders starting with “.” work.