404 not found error for acme challenge

Hello everyone,

very similar to the issue mentioned in the below link , i am facing the same problem.

I am using ZeroSSL and have created the public_html/.well-known/acme-challenge , placed the keys in the folder and checked the permissions as well.

As informed by JuergenAuer, i have created a test 12345 file in acme-challenge, and accessed via
http://talkpool.com/.well-known/acme-challenge/12345 and i get the same error

My domain is: talkpool.com

I ran this command: while verification of talkpool.com and www.talkpool.com, when i clicked on the keys link

It produced this output: 404 not found error ; oops the page cannot be found

My web server is (include version): apache 2.4.39

The operating system my web server runs on is (include version): linux

My hosting provider, if applicable, is: Godaddy

I can login to a root shell on my machine (yes or no, or I don't know): No

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

Any help to get this sorted is much appreciated


Hi @chandrajonnala

if that doesn't work, you may have created the /.well-known/acme-challenge in the wrong place.

There is a nginx.

What says

nginx -T

But if you don't have root access, it may be impossible to use http validation.

Or GoDaddy blocks the /.well-known/acme-challenge, so you can't use it.

JuergenAuer, Thank you for the response. there were some complications with the DNS and hosting provider so i cannot use the DNS validation as well.

If you do not mind, could you be more specific about the nginx -T, what is this?

if i can get the root access how would i know the correct place to put the /.well-know/acme-challenge? how do i check it

is there any alternative approach to get this sorted?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.