Win-acme and remote desktop


#1

I’m running Windows Server Essentials 2012 R2 in a remote location with a half dozen or so workstations. I’m using win-acme to generate and renew the IIS certificates for the site and the Remote Web Access page comes up clean. When I attempt to connect to any of the devices though I get:

“your computer can’t connect to the remote computer because your computer or device did not pass the Network Access Protection requirements set by your network administrator.”

Further examination reveals Event log entries like this:

“Critical Alert: TsGatewayConfiguration is raised at . Remote Desktop Services is not configured correctly. Remote Desktop Services is not configured correctly. You must configure Remote Desktop Services to remotely connect to computers in the network…”

Firing up the Remote Access Management Console’s Dashboard shows IP-HTTPS and Kerberos with errors, likely because Remote Access is still set with a self signed certificate instead of with the Let’s Encrypt cert. I’ve tried copying the certificate from the personal certificates store to the remote desktop store, but it’s not showing up as an option when I try to bind it to the network interface in remote access setup.

Has anyone got this working? How do you do it? Is there any way to do it through the win-acme interface so updates will happen for both IIS and Remote Desktop via the task scheduler?


#2

Hi @billsey

there is an article

Use the RD Gateway Manager to fix it.


#3

That in fact did have the info needed. I first had to install Remote Desktop Gateway Manager via a dism command (dism /online /Enable-Feature:Gateway-UI), then I had to copy the LE cert from Web Hosting certificates to Personal certificates and finally launch RDGM to associate the personal cert with RD.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.