Wilcard Subdomain Recognition


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: ancientlakescolumbiavalleyava.com

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:inmotionhosting

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):cpanel


#2

How do I get Let’s Encrypt to recognize my wildcard subdomain? I am using Wordpress multisites.


#3

Hi @Kitty

if you use cpanel, there is an integrated Letsencrypt-cpanel-client. This may be the best solution.

Check, if this exists.


#4

I don’t see a Let’s Encrypt cpanel client.


#5

The client is called autossl (for WHM / server owners), SSL status (for cPanel users)…

However, that feature build-in does not responsible for wildcard certificate… Hense you will still need to request & issue from a website & install to the server.

You could also reach to your server support and ask if they installed a plugin called fleetssl , which could help you request & install a wildcard certificate when your site’s ns is pointed to the server.

Thank you


#6

Thank you. I succeeded in installing verifying my wildcard domain and installing it. However, my Wordpress multisites are showing a red https on Chrome. It is fine on Edge and Safari (my iPhone) says that the server cannot be found and doesn’t display the page. Any insights?


#7

Hi,

Can you share me an sample address? (Since my chrome opens ancientlakescolumbiavalleyava.com correctly …)

Thank you


#8

https://evergreen.ancientlakescolumbiavalleyava.com/

Thank you for trying to assist me.


#9

Hi @Kitty,

Your hostname evergreen.ancientlakescolumbiavalleyava.com is invalid at your nameserver ns1.inmotionhosting.com. It has a TXT record, but no A record, so this host doesn’t exist from users’ point of view.

I briefly saw a cached record pointing it to 209.182.200.30 but then this expired from cache, which suggests to me that the DNS may have been set up correctly before but then been broken, or maybe that you have set the record up on some other nameserver which isn’t the appropriate nameserver for your domain. In this case, I think Safari is showing you the most correct and up-to-date information! However, this problem isn’t directly related to your certificate, only to your DNS settings. When we connect on 209.182.200.30, the server does serve a correct, valid wildcard certificate and site content.


#10

Hi @schoen,
I set it up through Wordpress multisites. the wildcard domain is *.ancientlakescolumbiavalleyava.com
Could that have been corrupted? If so, I can delete it and start again.
While I have been designing websites for several years, I only started working with Wordpress, wildcard subdomains, and ssl installations within the last few months.


#11

I don’t know how you manage your settings at your DNS provider, but you don’t have a wildcard DNS record in place at the DNS provider at the moment and so devices trying to connect to your site can’t locate it.


#12

I set it up through zone editor.


#13

It’s not in place now. Your wildcard A record has been replaced with a wildcard TXT record that is serving xrDAcWiWHmbt5ODI4BRCl56lb7qK9zfvStn1rZBXSX8 as a TXT value for every subdomain, rather than serving 209.182.200.30 as an A value for every subdomain.


#14

Thank you. I am sorry to ask, but how would I change it. I am doing a Google search to try and figure it out.


#15

Unfortunately, I don’t know anything about your zone editor. However, it’s presumably part of an account that you have with InMotion Hosting.


#16

@schoen Thank you. Since I haven’t designed the subdomain pages yet, I decided to start from scratch. Hopefully, it solves all issues because I just made the actual site live and sent it to my client. I really appreciate your help.


#17

Thank you once again for all of your help @stevenzhu and @schoen. The ssl is now working on the subdomains. :smile:


#18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.