Version Conflict FreeBSD


#1

I am getting a version conflict under FreeBSD when trying to run certbot.

I’ve removed all of certbot twice and done a make install clean and I still get VersionConflict: (acme 0.9.3 (/usr/local/lib/python2.7/site-packages), Requirement.parse('acme==0.5.0.dev0 when I try to run it. I’ve removed acme multiple times, but to no avail.

Someone in [this thread](http://VersionConflict: (acme 0.9.3 (/usr/local/lib/python2.7/site-packages), Requirement.parse('acme==0.5.0.dev0) mentioned fixing a similar error with pkg_cutleaves, but that is not something I have on my FreeBSD using portmaster, and I don’t know what they did anyway, so not sure how it would help.

# cd /usr/ports/security/py-certbot && make install clean ===> Cleaning for py27-acme-0.9.3,1 ===> Cleaning for py27-ndg_httpsclient-0.4.1 ===> Cleaning for py27-pyasn1-0.1.9 ===> Cleaning for py27-dnspython-1.15.0 ===> Cleaning for py27-idna-2.0 ===> Cleaning for py27-pyrfc3339-1.0 ===> Cleaning for py27-requests-2.11.1 ===> Cleaning for py27-werkzeug-0.11.11 ===> Cleaning for py27-funcsigs-1.0.2 ===> Cleaning for py27-mock-1.3.0_1 ===> Cleaning for py27-pbr-1.8.1 ===> Cleaning for py27-pip-8.1.2 ===> Cleaning for py27-configargparse-0.10.0 ===> Cleaning for py27-configobj-5.0.6_1 ===> Cleaning for py27-parsedatetime-2.1 ===> Cleaning for py27-psutil-4.3.0 ===> Cleaning for py27-python2-pythondialog-3.4.0 ===> Cleaning for py27-zope.component-4.2.2 ===> Cleaning for py27-zope.event-4.1.0 ===> Cleaning for py27-zope.interface-4.1.3 ===> Cleaning for py27-certbot-0.9.3,1


#2

I had the same issue. I ran “pkg info -rd py27-acme-0.9.3,1” and saw that py27-letsencrypt-0.1.0 was still installed along with py27-certbot-0.9.3,1. Deinstalled py27-letsencrypt-0.1.0 and all is happy again.


#3

I don’t have the old letsencrypt package installed:

pkg info -rd py27-acme-0.9.3,1
py27-acme-0.9.3,1
Depends on     :
    python27-2.7.12
    py27-setuptools27-28.1.0
    py27-six-1.10.0
    py27-requests-2.11.1
    py27-werkzeug-0.11.11
    py27-dnspython-1.15.0
    py27-openssl-16.0.0
    py27-ndg_httpsclient-0.4.1
    py27-cryptography-1.4
    py27-pyrfc3339-1.0
    py27-idna-2.0
    py27-pytz-2016.7,1
    py27-pyasn1-0.1.9
Required by    :
    py27-certbot-0.9.3,1

#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.