Gentoo system, VersionConflict


Not sure if this is even the right place for it, but I figures I’d at least give it a try.
The key output is:

pkg resources.VersionConflict: (certbot 0.16.0.dev0 (/usr/lib64/python3.4/site-packages), Requirement.parse(‘certbot==0.15.0.dev0’))

but I struggle to make sense of it…

I ran this command:

It produced this output:
An unexpected error occurred:
Traceback (most recent call last):
File “/usr/lib/python-exec/python3.4/certbot”, line 11, in
load_entry_point(‘certbot==0.16.0.dev0’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib64/python3.4/site-packages/certbot/”, line 723, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/lib64/python3.4/site-packages/certbot/plugins/”, line 201, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/lib64/python3.4/site-packages/certbot/plugins/”, line 48, in init
self.plugin_cls = entry_point.load()
File “/usr/lib64/python3.4/site-packages/pkg_resources/”, line 2295, in load
self.require(*args, **kwargs)
File “/usr/lib64/python3.4/site-packages/pkg_resources/”, line 2318, in require
items = working_set.resolve(reqs, env, installer, extras=self.extras)
File “/usr/lib64/python3.4/site-packages/pkg_resources/”, line 859, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.VersionConflict: (certbot 0.16.0.dev0 (/usr/lib64/python3.4/site-packages), Requirement.parse(‘certbot==0.15.0.dev0’))
Please see the logfile ‘/tmp/tmpl5at6ps8’ for more details.

My web server is (include version):
Server version: Apache/2.4.25 (Unix)

The operating system my web server runs on is (include version):

I can login to a root shell on my machine (yes or no, or I don’t know):


That’s odd… How did you install certbot?


#emerge certbot.

worked lovely until a couple of days ago.

I found this over at GitHub, indicating that it is a python 3.4 problem:

But I have no idea how to fix this.


emerge -av app-crypt/certbot-apache

seems to have fixed the problem…
Not sure why, maybe I just messed it up somehow.

Anyway, this is fixed now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.