Funky acme conflict on update


#1

myserver.org:/home/jason/src/letsencrypt # ./letsencrypt-auto renew
Updating letsencrypt and virtual environment dependencies…You are using pip version 8.0.3, however version 9.0.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

Running with virtualenv: /root/.local/share/letsencrypt/bin/letsencrypt renew
An unexpected error occurred:
VersionConflict: (acme 0.10.0 (/root/.local/share/letsencrypt/lib/python2.7/site-packages), Requirement.parse(‘acme==0.9.3’))
Please see the logfile ‘certbot.log’ for more details.
myserver.org:/home/jason/src/letsencrypt # cat certbot.log
Traceback (most recent call last):
File “/root/.local/share/letsencrypt/bin/letsencrypt”, line 11, in
sys.exit(main())
File “/root/.local/share/letsencrypt/lib/python2.7/site-packages/certbot/main.py”, line 825, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/root/.local/share/letsencrypt/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 183, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/root/.local/share/letsencrypt/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 34, in init
self.plugin_cls = entry_point.load()
File “/root/.local/share/letsencrypt/lib/python2.7/site-packages/pkg_resources/init.py”, line 2290, in load
self.require(*args, **kwargs)
File “/root/.local/share/letsencrypt/lib/python2.7/site-packages/pkg_resources/init.py”, line 2307, in require
items = working_set.resolve(reqs, env, installer)
File “/root/.local/share/letsencrypt/lib/python2.7/site-packages/pkg_resources/init.py”, line 854, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
VersionConflict: (acme 0.10.0 (/root/.local/share/letsencrypt/lib/python2.7/site-packages), Requirement.parse(‘acme==0.9.3’))
myserver.org:/home/jason/src/letsencrypt #


#2

what operating system are you on ?

Can you check what certbot or letsencrypt packages are installed ?


#3

centos 6.8

its the letsencrypt-auto script… I dont see a version number specified in the file…

I tried installing acme 0.9.3 and it seems to have worked…
Installing collected packages: acme
Found existing installation: acme 0.10.0
Uninstalling acme-0.10.0:
Successfully uninstalled acme-0.10.0
Successfully installed acme-0.9.3

but when i run the certbot-auto command, it still tells me that the acme 0.10.0 is conflicting…
yes im using python 2.7 on this centos 6 server…


#4

It sounds as if you’ve got a conflict between various versions / packages.

letsencrypt-auto --version

should hopefully show you the version you have installed for that. version 0.10.0 is the latest version of certbot

How were you installing “acme 0,10,0” ?


#5

myserver.org:~/src/letsencrypt $ ./letsencrypt-auto --version
Updating letsencrypt and virtual environment dependencies…
Running with virtualenv: sudo /home/jason/.local/share/letsencrypt/bin/letsencrypt --version
An unexpected error occurred:
VersionConflict: (acme 0.10.0 (/home/jason/.local/share/letsencrypt/lib/python2.7/site-packages), Requirement.parse(‘acme==0.9.3’))
Please see the logfile ‘certbot.log’ for more details.
myserver.org:~/src/letsencrypt $ ./letsencrypt-auto version
Updating letsencrypt and virtual environment dependencies…
Running with virtualenv: sudo /home/jason/.local/share/letsencrypt/bin/letsencrypt version
An unexpected error occurred:
VersionConflict: (acme 0.10.0 (/home/jason/.local/share/letsencrypt/lib/python2.7/site-packages), Requirement.parse(‘acme==0.9.3’))
Please see the logfile ‘certbot.log’ for more details.
myserver.org:~/src/letsencrypt $

I didnt specifically install the acme 0.10, so im not sure how/where it came from… letsencrypt is the only thing I use python 2.7 for on this server. I assume letsencrypt somehow pulled it in.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.