[Solved] Error with acme version while trying to renew


#1

Hello!
I’m trying to renew my certificate using certbot and I’m getting this error:
Could not find a version that satisfies the requirement acme==0.12.0

I have certbot cloned from the GitHub repo, and I have pulled the latest version.
The command I’m running is ./certbot-auto renew and this is the output:

Bootstrapping dependencies for Debian-based OSes...
Hit http://repo.ajenti.org main InRelease
Ign http://ppa.launchpad.net utopic InRelease
Get:1 http://repo.ajenti.org main/main amd64 Packages [6,759 B]
Ign http://es.archive.ubuntu.com trusty InRelease
Ign http://ppa.launchpad.net utopic InRelease
Ign http://ppa.launchpad.net utopic InRelease
Get:2 http://es.archive.ubuntu.com trusty-security InRelease [65.9 kB]
Ign http://ppa.launchpad.net utopic InRelease
Ign http://ppa.launchpad.net utopic Release.gpg
Err http://repo.ajenti.org main/ubuntu amd64 Packages
  Bad header line
Err http://repo.ajenti.org main/main i386 Packages
  0  Requested Range Not Satisfiable
Err http://repo.ajenti.org main/ubuntu i386 Packages
  0  Requested Range Not Satisfiable
Hit http://repo.ajenti.org main/ubuntu Translation-en
Hit http://repo.ajenti.org main/main Translation-en_US
Ign http://ppa.launchpad.net utopic Release.gpg
Get:3 http://es.archive.ubuntu.com trusty-updates InRelease [65.9 kB]
Ign http://ppa.launchpad.net utopic Release.gpg
Ign http://ppa.launchpad.net utopic Release.gpg
Get:4 http://es.archive.ubuntu.com trusty-proposed InRelease [65.9 kB]
Ign http://ppa.launchpad.net utopic Release
Get:5 http://es.archive.ubuntu.com trusty-backports InRelease [65.9 kB]
Ign http://repo.ajenti.org main/main Translation-en_US
Ign http://ppa.launchpad.net utopic Release
Ign http://repo.ajenti.org main/main Translation-en
Hit http://es.archive.ubuntu.com trusty Release.gpg
Ign http://ppa.launchpad.net utopic Release
Ign http://repo.ajenti.org main/ubuntu Translation-en_US
Ign http://repo.ajenti.org main/ubuntu Translation-en
Get:6 http://es.archive.ubuntu.com trusty-security/main Sources [126 kB]
Ign http://ppa.launchpad.net utopic Release
Get:7 http://es.archive.ubuntu.com trusty-security/restricted Sources [4,637 B]
Ign http://downloads-distro.mongodb.org dist InRelease
Get:8 http://es.archive.ubuntu.com trusty-security/universe Sources [49.9 kB]
Get:9 http://es.archive.ubuntu.com trusty-security/multiverse Sources [3,194 B]
Get:10 http://es.archive.ubuntu.com trusty-security/main amd64 Packages [589 kB]
Ign http://ppa.launchpad.net utopic/main amd64 Packages/DiffIndex
Ign http://ppa.launchpad.net utopic/main i386 Packages/DiffIndex
Get:11 http://es.archive.ubuntu.com trusty-security/restricted amd64 Packages [13.4 kB]
Get:12 http://es.archive.ubuntu.com trusty-security/universe amd64 Packages [154 kB]
Get:13 http://es.archive.ubuntu.com trusty-security/multiverse amd64 Packages [4,139 B]
Get:14 http://es.archive.ubuntu.com trusty-security/main i386 Packages [548 kB]
Hit https://deb.nodesource.com utopic InRelease
Get:15 http://es.archive.ubuntu.com trusty-security/restricted i386 Packages [13.1 kB]
Get:16 https://deb.nodesource.com utopic/main Sources
Get:17 https://deb.nodesource.com utopic/main amd64 Packages
Get:18 http://es.archive.ubuntu.com trusty-security/universe i386 Packages [154 kB]
Ign http://ppa.launchpad.net utopic/main amd64 Packages/DiffIndex
Get:19 https://deb.nodesource.com utopic/main i386 Packages
Hit http://downloads-distro.mongodb.org dist Release.gpg
Ign http://ppa.launchpad.net utopic/main i386 Packages/DiffIndex
Get:20 http://es.archive.ubuntu.com trusty-security/multiverse i386 Packages [4,278 B]
Get:21 http://es.archive.ubuntu.com trusty-updates/main Sources [393 kB]
Get:22 http://es.archive.ubuntu.com trusty-updates/restricted Sources [5,911 B]
Get:23 http://es.archive.ubuntu.com trusty-updates/universe Sources [175 kB]
Hit http://downloads-distro.mongodb.org dist Release
Get:24 http://es.archive.ubuntu.com trusty-updates/multiverse Sources [7,510 B]
Get:25 http://es.archive.ubuntu.com trusty-updates/main amd64 Packages [956 kB]
Get:26 http://es.archive.ubuntu.com trusty-updates/restricted amd64 Packages [16.4 kB]
Get:27 http://es.archive.ubuntu.com trusty-updates/universe amd64 Packages [400 kB]
Get:28 http://es.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [14.0 kB]
Get:29 http://es.archive.ubuntu.com trusty-updates/main i386 Packages [918 kB]
Get:30 https://deb.nodesource.com utopic/main Translation-en_US
Get:31 http://es.archive.ubuntu.com trusty-updates/restricted i386 Packages [16.2 kB]
Get:32 http://es.archive.ubuntu.com trusty-updates/universe i386 Packages [401 kB]
Get:33 http://es.archive.ubuntu.com trusty-updates/multiverse i386 Packages [14.4 kB]
Get:34 http://es.archive.ubuntu.com trusty-proposed/main Sources [114 kB]
Get:35 http://es.archive.ubuntu.com trusty-proposed/restricted Sources [1,892 B]
Get:36 http://es.archive.ubuntu.com trusty-proposed/universe Sources [16.5 kB]
Get:37 http://es.archive.ubuntu.com trusty-proposed/multiverse Sources [28 B]
Get:38 http://es.archive.ubuntu.com trusty-proposed/main amd64 Packages [92.4 kB]
Get:39 http://es.archive.ubuntu.com trusty-proposed/restricted amd64 Packages [3,751 B]
Get:40 http://es.archive.ubuntu.com trusty-proposed/universe amd64 Packages [11.1 kB]
Get:41 http://es.archive.ubuntu.com trusty-proposed/multiverse amd64 Packages [28 B]
Get:42 http://es.archive.ubuntu.com trusty-proposed/main i386 Packages [89.9 kB]
Get:43 http://es.archive.ubuntu.com trusty-proposed/restricted i386 Packages [3,743 B]
Get:44 http://es.archive.ubuntu.com trusty-proposed/universe i386 Packages [11.1 kB]
Get:45 http://es.archive.ubuntu.com trusty-proposed/multiverse i386 Packages [28 B]
Err http://ppa.launchpad.net utopic/main amd64 Packages
  404  Not Found
Err http://ppa.launchpad.net utopic/main i386 Packages
  404  Not Found
Ign http://ppa.launchpad.net utopic/main Translation-en_US
Hit http://es.archive.ubuntu.com trusty-proposed/multiverse Translation-en
Ign http://ppa.launchpad.net utopic/main Translation-en
Get:46 http://es.archive.ubuntu.com trusty-backports/main Sources [9,712 B]
Get:47 http://es.archive.ubuntu.com trusty-backports/restricted Sources [28 B]
Get:48 http://es.archive.ubuntu.com trusty-backports/universe Sources [35.3 kB]
Get:49 http://es.archive.ubuntu.com trusty-backports/multiverse Sources [1,898 B]
Get:50 http://es.archive.ubuntu.com trusty-backports/main amd64 Packages [13.3 kB]
Ign http://ppa.launchpad.net utopic/main Translation-en_US
Get:51 http://es.archive.ubuntu.com trusty-backports/restricted amd64 Packages [28 B]
Ign http://ppa.launchpad.net utopic/main Translation-en
Err http://ppa.launchpad.net utopic/main amd64 Packages
  404  Not Found
Get:52 http://es.archive.ubuntu.com trusty-backports/universe amd64 Packages [43.2 kB]
Err http://ppa.launchpad.net utopic/main i386 Packages
  404  Not Found
Get:53 http://es.archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1,571 B]
Ign http://ppa.launchpad.net utopic/main Translation-en_US
Get:54 http://es.archive.ubuntu.com trusty-backports/main i386 Packages [13.3 kB]
Ign http://ppa.launchpad.net utopic/main Translation-en
Get:55 http://es.archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
Get:56 http://es.archive.ubuntu.com trusty-backports/universe i386 Packages [43.2 kB]
Get:57 http://es.archive.ubuntu.com trusty-backports/multiverse i386 Packages [1,552 B]
Ign http://ppa.launchpad.net utopic/main Translation-en_US
Ign http://ppa.launchpad.net utopic/main Translation-en
Err http://ppa.launchpad.net utopic/main amd64 Packages
  404  Not Found
Err http://ppa.launchpad.net utopic/main i386 Packages
  404  Not Found
Err http://ppa.launchpad.net utopic/main amd64 Packages
  404  Not Found
Err http://ppa.launchpad.net utopic/main i386 Packages
  404  Not Found
Hit http://es.archive.ubuntu.com trusty-backports/restricted Translation-en
Hit http://es.archive.ubuntu.com trusty Release
Hit http://es.archive.ubuntu.com trusty-security/main Translation-en
Hit http://downloads-distro.mongodb.org dist/10gen amd64 Packages
Hit http://es.archive.ubuntu.com trusty-security/multiverse Translation-en
Hit http://es.archive.ubuntu.com trusty-security/restricted Translation-en
Hit http://es.archive.ubuntu.com trusty-security/universe Translation-en
Hit http://es.archive.ubuntu.com trusty-updates/main Translation-en
Hit http://es.archive.ubuntu.com trusty-updates/multiverse Translation-en
Hit http://es.archive.ubuntu.com trusty-updates/restricted Translation-en
Hit http://es.archive.ubuntu.com trusty-updates/universe Translation-en
Hit http://es.archive.ubuntu.com trusty-proposed/main Translation-en
Hit http://es.archive.ubuntu.com trusty-proposed/restricted Translation-en
Hit http://es.archive.ubuntu.com trusty-proposed/universe Translation-en
Hit http://es.archive.ubuntu.com trusty-backports/main Translation-en
Hit http://es.archive.ubuntu.com trusty-backports/multiverse Translation-en
Hit http://es.archive.ubuntu.com trusty-backports/universe Translation-en
Hit http://downloads-distro.mongodb.org dist/10gen i386 Packages
Ign https://deb.nodesource.com utopic/main Translation-en_US
Ign https://deb.nodesource.com utopic/main Translation-en
Hit http://es.archive.ubuntu.com trusty/main Sources
Hit http://es.archive.ubuntu.com trusty/restricted Sources
Hit http://es.archive.ubuntu.com trusty/universe Sources
Hit http://es.archive.ubuntu.com trusty/multiverse Sources
Hit http://es.archive.ubuntu.com trusty/main amd64 Packages
Hit http://es.archive.ubuntu.com trusty/restricted amd64 Packages
Hit http://es.archive.ubuntu.com trusty/universe amd64 Packages
Hit http://es.archive.ubuntu.com trusty/multiverse amd64 Packages
Hit http://es.archive.ubuntu.com trusty/main i386 Packages
Hit http://es.archive.ubuntu.com trusty/restricted i386 Packages
Hit http://es.archive.ubuntu.com trusty/universe i386 Packages
Hit http://es.archive.ubuntu.com trusty/multiverse i386 Packages
Hit http://es.archive.ubuntu.com trusty/main Translation-en
Hit http://es.archive.ubuntu.com trusty/multiverse Translation-en
Hit http://es.archive.ubuntu.com trusty/restricted Translation-en
Hit http://es.archive.ubuntu.com trusty/universe Translation-en
Ign http://es.archive.ubuntu.com trusty/main Translation-en_US
Ign http://es.archive.ubuntu.com trusty/multiverse Translation-en_US
Ign http://es.archive.ubuntu.com trusty/restricted Translation-en_US
Ign http://es.archive.ubuntu.com trusty/universe Translation-en_US
Ign http://downloads-distro.mongodb.org dist/10gen Translation-en_US
Ign http://downloads-distro.mongodb.org dist/10gen Translation-en
Fetched 5,754 kB in 5s (1,037 kB/s)
W: Failed to fetch http://repo.ajenti.org/ng/debian/dists/main/ubuntu/binary-amd64/Packages  Bad header line

W: Failed to fetch http://repo.ajenti.org/ng/debian/dists/main/main/binary-i386/Packages  0  Requested Range Not Satisfiable

W: Failed to fetch http://repo.ajenti.org/ng/debian/dists/main/ubuntu/binary-i386/Packages  0  Requested Range Not Satisfiable

W: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/dists/utopic/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/dists/utopic/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ondrej/php5-oldstable/ubuntu/dists/utopic/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ondrej/php5-oldstable/ubuntu/dists/utopic/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/dists/utopic/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/dists/utopic/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ondrej/php5/ubuntu/dists/utopic/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/ondrej/php5/ubuntu/dists/utopic/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
apt-get update hit problems but continuing anyway...
Reading package lists... Done
Building dependency tree
Reading state information... Done
ca-certificates is already the newest version.
openssl is already the newest version.
python is already the newest version.
python-dev is already the newest version.
libffi-dev is already the newest version.
libaugeas0 is already the newest version.
libssl-dev is already the newest version.
gcc is already the newest version.
python-virtualenv is already the newest version.
virtualenv is already the newest version.
augeas-lenses is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
Creating virtual environment...
Installing Python packages...
Had a problem while installing Python packages.

pip prints the following errors:
=====================================================
Collecting argparse==1.4.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 11))
  Downloading http://mirrors.aliyun.com/pypi/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Collecting pycparser==2.14 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 17))
  Downloading http://mirrors.aliyun.com/pypi/packages/6d/31/666614af3db0acf377876d48688c5d334b6e493b96d21aa7d332169bee50/pycparser-2.14.tar.gz (223kB)
Collecting cffi==1.4.2 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 21))
  Downloading http://mirrors.aliyun.com/pypi/packages/92/00/c8670a2898ab7121cdac3b59f4307977a86e08a59efd662f6c05200a2f11/cffi-1.4.2.tar.gz (365kB)
Collecting ConfigArgParse==0.10.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 38))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/simple/configargparse/
  Downloading http://mirrors.aliyun.com/pypi/packages/d0/b8/8f7689980caa66fc02671f5837dc761e4c7a47c6ca31b3e38b304cbc3e73/ConfigArgParse-0.10.0.tar.gz
Collecting configobj==5.0.6 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 40))
  Downloading http://mirrors.aliyun.com/pypi/packages/64/61/079eb60459c44929e684fa7d9e2fdca403f67d64dd9dbac27296be2e0fab/configobj-5.0.6.tar.gz
Collecting cryptography==1.5.3 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 42))
  Downloading http://mirrors.aliyun.com/pypi/packages/6c/c5/7fc1f8384443abd2d71631ead026eb59863a58cad0149b94b89f08c8002f/cryptography-1.5.3.tar.gz (400kB)
Collecting enum34==1.1.2 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 65))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/simple/enum34/
  Downloading http://mirrors.aliyun.com/pypi/packages/6f/e9/08fd439384b7e3d613e75a6c8236b8e64d90c47d23413493b38d4229a9a5/enum34-1.1.2.tar.gz (46kB)
Collecting funcsigs==0.4 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 68))
  Downloading http://mirrors.aliyun.com/pypi/packages/5e/9f/025d4c92c6a1a94313cdf0813cd76f5700f8e5434fa15165090a6446ae22/funcsigs-0.4-py2.py3-none-any.whl
Collecting idna==2.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 71))
  Downloading http://mirrors.aliyun.com/pypi/packages/7c/75/b566d769455929ee6ab308d8a1c6c5aecc4928e72b25d42dd019c99f7015/idna-2.0-py2.py3-none-any.whl (61kB)
Collecting ipaddress==1.0.16 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 74))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/packages/23/6a/813ac29a01e4c33c19c2bded98ac3d4266ebbf0bd2c0eb0020e1c969958d/ipaddress-1.0.16-py27-none-any.whl
  Downloading http://mirrors.aliyun.com/pypi/packages/23/6a/813ac29a01e4c33c19c2bded98ac3d4266ebbf0bd2c0eb0020e1c969958d/ipaddress-1.0.16-py27-none-any.whl
Collecting linecache2==1.0.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 77))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/simple/linecache2/
  Downloading http://mirrors.aliyun.com/pypi/packages/c7/a3/c5da2a44c85bfbb6eebcfc1dde24933f8704441b98fdde6528f4831757a6/linecache2-1.0.0-py2.py3-none-any.whl
Collecting ordereddict==1.1 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 80))
  Downloading http://mirrors.aliyun.com/pypi/packages/53/25/ef88e8e45db141faa9598fbf7ad0062df8f50f881a36ed6a0073e1572126/ordereddict-1.1.tar.gz
Collecting parsedatetime==2.1 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 82))
  Downloading http://mirrors.aliyun.com/pypi/packages/85/1f/13fc06097e516f6259d62cea502b116451321c96e18a9d0fff9da3442e02/parsedatetime-2.1-py2-none-any.whl
Collecting pbr==1.8.1 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 85))
  Downloading http://mirrors.aliyun.com/pypi/packages/fc/37/94af8387babb09796d306b18cf94ee5c70388c875a16d8a88e471500452c/pbr-1.8.1-py2.py3-none-any.whl (89kB)
Collecting pyasn1==0.1.9 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 88))
  Downloading http://mirrors.aliyun.com/pypi/packages/69/be/e8946f7867b84b0e61a613f6fd56f63266190b1a470f945178f7cbc4d0ae/pyasn1-0.1.9-py2.py3-none-any.whl
Collecting pyOpenSSL==16.2.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 100))
  Downloading http://mirrors.aliyun.com/pypi/packages/ac/93/b4cd538d31adacd07f83013860db6b88d78755af1f3fefe68ec22d397e7b/pyOpenSSL-16.2.0-py2.py3-none-any.whl (43kB)
Collecting pyparsing==2.1.8 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 103))
  Downloading http://mirrors.aliyun.com/pypi/packages/85/b9/188515f35f78533b3f82966a2c3f1a71a86df8b801367ee75a77191a861d/pyparsing-2.1.8-py2.py3-none-any.whl (54kB)
Collecting pyRFC3339==1.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 112))
  Downloading http://mirrors.aliyun.com/pypi/packages/9b/0a/decfa17e7707afca17d6e9595ff5c79c1c71c74063ad95576f897ed3a9f1/pyRFC3339-1.0-py2.py3-none-any.whl
Collecting python-augeas==0.5.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 115))
  Downloading http://mirrors.aliyun.com/pypi/packages/41/e6/4b6740cb3e31b82252099994cea751c648b846aa7874343c31d68c2215be/python-augeas-0.5.0.tar.gz (90kB)
Collecting pytz==2015.7 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 117))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/packages/c0/28/973f0382c803b21734cd7e97e0590928148ee21b1cbe8f7fed8b506204fb/pytz-2015.7-py2.py3-none-any.whl
  Downloading http://mirrors.aliyun.com/pypi/packages/c0/28/973f0382c803b21734cd7e97e0590928148ee21b1cbe8f7fed8b506204fb/pytz-2015.7-py2.py3-none-any.whl (476kB)
Collecting requests==2.12.1 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 131))
  Downloading http://mirrors.aliyun.com/pypi/packages/9b/31/e9925a2b9a06f97c3450bac6107928d3533bfe64ca5615442504104321e8/requests-2.12.1-py2.py3-none-any.whl (574kB)
Collecting six==1.10.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 134))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/simple/six/
  Downloading http://mirrors.aliyun.com/pypi/packages/c8/0a/b6723e1bc4c516cb687841499455a8505b44607ab535be01091c0f24f079/six-1.10.0-py2.py3-none-any.whl
Collecting traceback2==1.4.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 137))
  Downloading http://mirrors.aliyun.com/pypi/packages/17/0a/6ac05a3723017a967193456a2efa0aa9ac4b51456891af1e2353bb9de21e/traceback2-1.4.0-py2.py3-none-any.whl
Collecting unittest2==1.1.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 140))
  Downloading http://mirrors.aliyun.com/pypi/packages/72/20/7f0f433060a962200b7272b8c12ba90ef5b903e218174301d0abfd523813/unittest2-1.1.0-py2.py3-none-any.whl (96kB)
Collecting zope.component==4.2.2 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 143))
  Downloading http://mirrors.aliyun.com/pypi/packages/4c/c4/3f77127c876f49af478e8ea4dc223cda17730bb273c0d1606a4114c64008/zope.component-4.2.2.tar.gz (546kB)
Collecting zope.event==4.1.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 145))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/simple/zope.event/
  Downloading http://mirrors.aliyun.com/pypi/packages/0e/87/75e3d62a3506953c2e56d15a150de31e5d92310e87db2c8b102dc01b0b8e/zope.event-4.1.0.tar.gz (476kB)
Collecting zope.interface==4.1.3 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 147))
  Downloading http://mirrors.aliyun.com/pypi/packages/9d/81/2509ca3c6f59080123c1a8a97125eb48414022618cec0e64eb1313727bfe/zope.interface-4.1.3.tar.gz (141kB)
Collecting mock==1.0.1 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 165))
  Downloading http://mirrors.aliyun.com/pypi/packages/15/45/30273ee91feb60dabb8fbb2da7868520525f02cf910279b3047182feed80/mock-1.0.1.zip (861kB)
Collecting letsencrypt==0.7.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 168))
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', BadStatusLine("''",))': /pypi/simple/letsencrypt/
  Downloading http://mirrors.aliyun.com/pypi/packages/fd/21/0c6f33829fadec8aca0c1ebb4d6f8101c05899356a58d1b2e506cb77cf18/letsencrypt-0.7.0-py2-none-any.whl
Collecting acme==0.12.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 174))
  Could not find a version that satisfies the requirement acme==0.12.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 174)) (from versions: 0.0.0.dev20151006, 0.0.0.dev20151008, 0.0.0.dev20151017, 0.0.0.dev20151020, 0.0.0.dev20151021, 0.0.0.dev20151024, 0.0.0.dev20151030, 0.0.0.dev20151104, 0.0.0.dev20151107, 0.0.0.dev20151108, 0.0.0.dev20151114, 0.0.0.dev20151123, 0.0.0.dev20151201, 0.1.0, 0.1.1, 0.2.0, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.5.0, 0.6.0, 0.7.0, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.11.1)
No matching distribution found for acme==0.12.0 (from -r /tmp/tmp.F4yvZfpBPc/letsencrypt-auto-requirements.txt (line 174))
You are using pip version 8.0.3, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
=====================================================

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .

I also tried running certbot on verbose mode, and this is the output (the relevant part only):

Downloading http://mirrors.aliyun.com/pypi/packages/fd/21/0c6f33829fadec8aca0c1ebb4d6f8101c05899356a58d1b2e506cb77cf18/letsencrypt-0.7.0-py2-none-any.whl
Collecting acme==0.12.0 (from -r /tmp/tmp.3DJYwWagzg/letsencrypt-auto-requirements.txt (line 174))
  Could not find a version that satisfies the requirement acme==0.12.0 (from -r /tmp/tmp.3DJYwWagzg/letsencrypt-auto-requirements.txt (line 174)) (from versions: 0.0.0.dev20151006, 0.0.0.dev20151008, 0.0.0.dev20151017, 0.0.0.dev20151020, 0.0.0.dev20151021, 0.0.0.dev20151024, 0.0.0.dev20151030, 0.0.0.dev20151104, 0.0.0.dev20151107, 0.0.0.dev20151108, 0.0.0.dev20151114, 0.0.0.dev20151123, 0.0.0.dev20151201, 0.1.0, 0.1.1, 0.2.0, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.5.0, 0.6.0, 0.7.0, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.11.1)
No matching distribution found for acme==0.12.0 (from -r /tmp/tmp.3DJYwWagzg/letsencrypt-auto-requirements.txt (line 174))

Any ideas of what could be causing this problem?
At first I thought it was a memory problem (has happened before), so I created a swap memory, but the problem remains.

Any help will be highly appreciated.
Thanks!


#2

i believe your issue can be fixed by fixing the following behaviour

–no-self-upgrade (certbot-auto only) prevent the certbot-auto script
from upgrading itself to newer released versions
(default: Upgrade automatically)


#3

Thanks for your answer!

I just fixed it. I opened a GitHub issue and one of the guys told me:

because of you set pip mirror is aliyun.com,just set origin mirror

mv ~/.pip/pip.conf ~/.pip/pip.conf.backup
or something else

I think may aliyun mirror is not latest version of acme

And that was it! It works now :slight_smile:
Thanks again.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.