VersionConflict: acme 0.15.0

Hi Togehther

  1. I ran this command: ./letsencrypt-auto certonly
  2. It produced this output:
    VersionConflict: (acme 0.15.0 (/root/.local/share/letsencrypt/lib/python2.7/site-packages), Requirement.parse(‘acme==0.14.2’))
  3. My web server is (include version): Apache version 2.4.16
  4. The operating system my web server runs on is (include version): SuSE Linux 42.1

How can i solve the issue from point 2 ?

Hi. I am running into the same problem. Did you solve this?

Sorry, but i’ve also no solution at the moment.

@SwartzCr, could you look into this a little? (packaging issues)

Strange! It seems as if your acme package updated without your version of certbot updating. (certbot is the new name for letsencrypt)
Can you let me know what version of letsencrypt you have? If it’s 0.14.2 then that seems like the problem. I’m curious why letsencrypt-auto isn’t updating itself, are you running it with --no-self-upgrade?
Has this problem resolved now that we’ve released 0.16.0?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.