Certbot 0.25.1 Release


#1

Certbot 0.25.1 has been released.

After the release, there was a brief period where certbot-auto was failing to upgrade to the newest version. This issue has been resolved. See https://community.letsencrypt.org/t/upgrading-certbot-auto-0-25-0-to-0-25-1 for more info.

The changelog for the 0.25.1 release is:

0.25.1 - 2018-06-13

Fixed

  • TLS-ALPN-01 support has been removed from our acme library. Using our current dependencies, we are unable to provide a correct implementation of this challenge so we decided to remove it from the library until we can provide proper support.
  • Issues causing test failures when running the tests in the acme package with pytest<3.0 has been resolved.
  • certbot-nginx now correctly depends on acme>=0.25.0.

Despite us having broken lockstep, we are continuing to release new versions of all Certbot components during releases for the time being, however, the only packages with changes other than their version number were:

  • acme
  • certbot-nginx

More details about these changes can be found on our GitHub repo:


Verification on non standard port 80
#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.