Version conflict centos 7


#1

I reviewed the various “version conflict” threads. I’ve done the “wheel tools” update as suggested and it ran without error.

python -m pip install --upgrade pip setuptools wheel

I also tried deleting the /opt/eff.org directory, though I now have that directory present since I did a restore from an image. I have done a yum remove certbot then yum install certbot. Clearly something isn’t being removed and or updated.

I am on Digital Ocean and use the following script, well when certbot worked. :wink:

certbot certonly --dns-digitalocean --dns-digitalocean-credentials /etc/letsencrypt/digitalocean/credentials.ini --dns-digitalocean-propagation-seconds 60 -d example.com

I had at one time set up certbot from git when the centos rev didn’t work. But I believe (hope!) I ran it in the virtual mode so it didn’t effect the installed files.

uname -a
Linux centos-1gb-sfo1-01 3.10.0-862.3.2.el7.x86_64 #1 SMP Mon May 21 23:36:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

cat /tmp/tmpPHVa3a

2018-06-05 09:52:05,817:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
File “/bin/certbot”, line 9, in
load_entry_point(‘certbot==0.24.0’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python2.7/site-packages/certbot/main.py”, line 1289, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 200, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 46, in init
self.plugin_cls = entry_point.load()
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 2317, in load
self.require(*args, **kwargs)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 2340, in require
items = working_set.resolve(reqs, env, installer, extras=self.extras)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 779, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
VersionConflict: (acme 0.24.0 (/usr/lib/python2.7/site-packages), Requirement.parse(‘acme==0.21.0’))
2018-06-05 09:52:05,817:ERROR:certbot.log:An unexpected error occurred:


#2

Take an inventory of your system.

rpm -qa | grep -E "(certbot|letsencrypt|acme)"
pip list | grep -E "(certbot|letsencrypt|acme)"

From there, hopefully you can clean it up.


#3

I cleaning it up with pip. I updated the certs for a low traffic website and will check it out. The digital ocean plugin seems not to be needed anymore. This is kind of confusing since it used a Digital Ocean token. I just ran certbot without arguments, then selected the domains.

Here is the pip removal, which might be useful for someone else.

pip list | grep -E "(certbot|letsencrypt|acme)"
acme                             0.24.0 
certbot                          0.24.0 
certbot-dns-digitalocean         0.21.0 
certbot-nginx                    0.24.0 

sh-4.2# pip uninstall certbot-dns-digitalocean 
Uninstalling certbot-dns-digitalocean-0.21.0:
 Would remove:
/usr/lib/python2.7/site-packages/certbot_dns_digitalocean-0.21.0.dist-info/*
/usr/lib/python2.7/site-packages/certbot_dns_digitalocean/*
Proceed (y/n)? y
Successfully uninstalled certbot-dns-digitalocean-0.21.0

#4

Thanks for your help. I’m closing this thread. I have a cert problem, but it doesn’t seem to be related to certbot.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.