Centos 7 certbot 29 not working

#1

My domain is:
cms.brettyoung.ca

I ran this command:
certbot --nginx

It produced this output:
Traceback (most recent call last):
File “/usr/bin/certbot”, line 5, in
from pkg_resources import load_entry_point
File “/usr/lib/python2.7/site-packages/pkg_resources.py”, line 3011, in
parse_requirements(requires), Environment()
File “/usr/lib/python2.7/site-packages/pkg_resources.py”, line 626, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: acme>=0.29.0

My web server is (include version):
nginx/1.12.2

The operating system my web server runs on is (include version):
Centos 7.5.1804

My hosting provider, if applicable, is:
Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
The command is not working, but the package installed is 0.29.1-1.el7

#2

Also I thought I’d mention that I did an update from 0.27 to 0.29 and that is when these issues started. I’ve tried to remove all the certbot packages:

yum remove certbot python2-certbot python2-certbot-nginx

Then reinstall:

yum install python2-certbot-nginx

But I still get the same error.

1 Like
#3

Looks like the solution here is to install python-acme:

yum install python-acme

Seems strange that if certbot requires it, that it wouldn’t install it automatically.

2 Likes
closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.