Centos 7 yum reinstall certbot-nginx does not work

I’ve installed certbot-nginx on Centos 7. I tried to run the http challenge and it didn’t work (I think because of my firewall). I have busted the rate limit. But after 1h I retried to run the certbot script and nothing happened. Maybe I overwrote the certbot file. So I decided to do a

yum reinstall certbot-nginx

After running it the certbot file didn’t reappear so I am not able to recover. Can someone help me on this?

My domain is:


I ran this command:

certbot --nginx -d callauth.isptelecom.net

It produced this output:

-bash: certbot: command not found

My web server is (include version):

nginx version: nginx/1.16.0

The operating system my web server runs on is (include version):

Centos 7

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): N/A

Per https://certbot.eff.org/lets-encrypt/centosrhel7-nginx , the package names are certbot and python2-certbot-nginx.

What happens when you try to follow the instructions above? The output of yum is the most important part.

@_az, I did reinstalled both packages without success. I fixed the issue by creating the missing script manually(/usr/bin/certbot-2) based on another image that I had. Everything is working well now. I have no clue why this file disapeared. I was especting that if I reinstall everything it should work but it was not the case. Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.