Using Munin with Let's Encrypt (certificate verify failed) #420


#1

Hey,

I tried to use Munin with Let’s Encrypt but I run into the following issue:
SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

I googled a bit and found something about MySQL, config setting seems to be similar:

Still returns me the same error.

My SSL settings for munin which are placed into munin.conf and munin-node.conf are the following:

tls paranoid
tls_verify_certificate yes
tls_private_key /etc/munin/keys/privkey.pem
tls_certificate /etc/munin/keys/cert.pem
tls_ca_certificate /etc/munin/keys/chain.pem
tls_verify_depth 5

Certificate Files I used from Let’s Encrypt, according to the Post above:

/etc/letsencrypt/live/DOMAIN.pw/privkey.pem
/etc/letsencrypt/live/DOMAIN.pw/cert.pem
/etc/letsencrypt/live/DOMAIN.pw/chain.pem

And It still returns the certificate validation error.
Anyone got an idea?


#2

Hi @Neoon,

You could find out what Munin is sending back to TLS clients with

openssl s_client -connect host:port -servername host

where host is the hostname and port is the port number.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.