Having touble getting let's encrypt to work on my Webmin/virtualmin server


#1

Hiya,

I want TLS and ssl to work on my let’s encrypt.

when i first found let’s encrypt i used the certbot cli guides online, but this seems to have messed up my server.

When i try and use Virtualmin/webmin let’s encrypt function, it says i need to use the certs generated by native.

I would rather it all just work in the Gui. is there anyway i can regress the certbot certs and move to the gui, or put the certbot generated certs into the gui?

i’m really confused.

The error i get in webmin is: The native Let’s Encrypt client was used previously on this system, and must be used for all future certificate requests

and i have no clue how to use the native client certs on webmin.

can anyone help?


#2

+1

I’ve previously been using this script.


#3

If you don’t mind re-creating all your previous certificates, you can simply delete /opt/letsencrypt and /etc/letsencrypt and the module will start working.


#4

Fantastic, thanks so much, it seems I have now made some progress.

Still have a minor snag though.

I can only get a Certificate by putting /var/www/html in the folder box (On webmin letsencrypt plugin)

but when I try and make a cert for my hostname + Multiple domains I run into lots of trouble.

Requesting a new certificate for , , , , using the website directory /var/www/html …
… request failed : Failed to request certificate :

ValueError: Wrote file to /var/www/html/.well-known/acme-challenge/xxxxx, but couldn’t download http:///.well-known/acme-challenge/xxxxx


#5

Where are you entering that? I didn’t need to change any settings, it just worked out the box. I had the odd domain that add permission issues on the .well-known folder, but you can just delete that and it’ll recreate that.


#6

if i do my

I get: Failed to request certificate : No virtual host matching was found


#7

Please see images below


#8

image 2