Using Let's Encrypt for .aero TLD?

I’ve tried to get a Let’s Encrypt certificate using the Plesk extension. It usually works seemlessly but this time I’m getting the following response. Could be it be because I’m using a .aero domain TLD which I haven’t tried before?

My domain is:

I ran this command: I used the Plesk Let’s Encrypt extension and clicked install as I usually do.

It produced this output:
Invalid response from
Type: urn:ietf:params:acme:error:orderNotReady
Status: 403
Detail: Order’s status (“pending”) is not acceptable for finalization

My web server is (include version): VPS with Linux 2.6.32-042stab133.1

The operating system my web server runs on is (include version): CentOS 6.6

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx 17.8.11

1 Like

Hi @stuartb

that's a known Plesk bug.


It's not a problem of .aero domains. There are a lot of Letsencrypt certificates with .aero.


Thanks for the quick reply Juergen! I updated Plesk and it worked perfectly :slight_smile:


Ah, thanks - good to know. So now there is a direct update that helps. So that workaround isn't longer required. :+1:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.